• September 20, 2019, 01:28:29 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: How to get Access Control to work?  (Read 1818 times)

mantorok

  • Level 1 Member
  • *
  • Posts: 11
How to get Access Control to work?
« on: April 25, 2014, 10:40:27 PM »


Hi,

I'm having a problem getting the Access Control feature on my DIR-868L to work. I'm trying to prevent my iPad from accessing youtube.com.  To do this I:

1. Created a Schedule (under Tools > Schedules) which is currently set to all days (checked individually) and time frame is 0:00 to 23:59. This is just to test if it works.  Eventually I'll set it to only certain days and a smaller time frame.

2. Created a Website filter (under Advanced > Website Filter) and set it to "DENY computers access to ONLY these sites" and added "youtube.com" to the list

3. Created a new Access Control Policy (under Advanced > Access Control) using
 a) the schedule created in step 1 above
 b) the MAC address of the iPad
 c) "Block Some Access" selected and "Apply Web Filter" checked. ("Apply Advanced Port Filters" is not checked)
 d) "Web Access Logging" set to Disabled

4. Rebooted the router and enabled the new policy.

After doing all this the iPad is still able to access youtube content. Have I missed something? Has anyone else got Access Control to work?

NOTE: I'm currently running firmware 1.07 and followed the recommended procedure when upgrading from 1.06. I restored router config from file, not manually re-entered from scratch.  I'm in Australia and the firmware was sourced from https://au.mydlink.com/support
Thanks,
Mantorok
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47761
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: How to get Access Control to work?
« Reply #1 on: April 27, 2014, 10:14:09 AM »

As a test, can you block ALL access to the internet and does it work using the filter?

Do you have a IP address reservation set up for the iPad?
Is DNS Relay enabled or disabled?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

mantorok

  • Level 1 Member
  • *
  • Posts: 11
Re: How to get Access Control to work?
« Reply #2 on: April 28, 2014, 01:37:07 AM »

I figured it out.  It was all set up correctly but I didn't realise that the YouTube app on the iPad doesn't use the youtube.com domain.  For some reason it uses googlevideo.com.

When I added googlevideo.com to the Website filter the YouTube app was unable to play any videos (which is what I wanted).
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47761
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: How to get Access Control to work? (RESOLVED)
« Reply #3 on: April 28, 2014, 07:58:29 AM »

Does help to have the correct domain I guess.  ::) Glad you got it figured out.

Enjoy.  ;)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting