• November 18, 2019, 06:34:47 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3 ... 7

Author Topic: Firmware 1.04 QoS Mod - Finally!  (Read 61462 times)

shm0

  • Level 2 Member
  • **
  • Posts: 51
Firmware 1.04 QoS Mod - Finally!
« on: February 07, 2014, 11:37:28 AM »

hey guys!
i finally managed to modify the 1.04 firmware to allow QoS on more then 2Mbit Upload. (Raised to 20mbit)

Proof:




https://drive.google.com/file/d/0B87wL7scXNdhdWwxTjFDb1JocE0/view?usp=sharing

Use at your own risk im not responsible for any bricked devices.

If you where brave enough to test, please share your experience.

I posted these files on my google drive for users to download:
DIR-857:
Firmware 1.04 QoS Mod

DIR-655 Rev B Only:
Firmware v2.11 QoS Mod

Please follow this for applying FW updates: Link> >FW Update Process

Furry
« Last Edit: July 13, 2016, 08:40:20 AM by FurryNutz »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #1 on: February 07, 2014, 11:51:52 AM »

How did you effect this? Is this built on NA region FW or EU region FW?

Thanks for sharing...I Might give this a go if this is on NA FW.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

shm0

  • Level 2 Member
  • **
  • Posts: 51
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #2 on: February 07, 2014, 12:08:36 PM »

I used the 1.0 Source/Toolkit.
Extracted the files from 1.04 firmware.

In the Source there are two folders. One for the romfs and one for vendor specific files.
replaced every file in both folders with the files from 1.04.

Run a make romfs and make image to get the bin.

It is based on the 1.04b9 from DLink CA Site. Hower the eu 1.04 firmware is the same. (Same Hash)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #3 on: February 07, 2014, 12:21:20 PM »

Awesome, I'll give this a go...What did you change to effect the 2Mb Uplink cap?

Curious, would you be able to do this for the DIR-827 and 657 maybe?  ???
« Last Edit: February 07, 2014, 12:36:35 PM by FurryNutz »
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

shm0

  • Level 2 Member
  • **
  • Posts: 51
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #4 on: February 07, 2014, 01:33:00 PM »

I just changed the script that initializes the QoS Engine and the QoS Webpage to allow higher Upload.

I guess that should be possible also for other devices.

But first this needs good testing if there is any negative impact.
Please also report how it is working for you.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #5 on: February 07, 2014, 01:37:37 PM »

Ok, will give this a go this weekend and see.

What code is exactly changed. Please feel free to post.

Thanks for doing this and sharing.

I'll recommend that users seeing this be aware that this is not a official release of FW and is not supported by D-Link and may invalidate any warranties users may have on the router. This is a un-supported modification.
If users choose to try this, please use the FW Update Process.
« Last Edit: December 04, 2014, 01:13:43 PM by FurryNutz »
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

shm0

  • Level 2 Member
  • **
  • Posts: 51
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #6 on: February 07, 2014, 01:44:57 PM »

It is the same change as i did on the 1.0 firmware. the thread must be somewhere here.


Code: [Select]
if [ $RATEEST_RETURN_VALUE -ne "0" ] ; then
echo Rate estimation failed - streamengine shaper will not start
/etc/init.d/se_unload
STREAMENGINE_SHAPER_LOADED=0
else
#
# If the detected speed is > 2000000 (2mbps) then we disable the shaper.
#  - we assume there is enough upstream bandwidth so as not to need a shaper
#
TX_RATE_BPS=$(cat /sys/devices/system/ubicom_streamengine/ubicom_streamengine0/ubicom_streamengine_calculated_rate)
if [ $TX_RATE_BPS -gt 2000000 ] ; then
cp -rf /sys/devices/system/ubicom_streamengine/ubicom_streamengine0/ubicom_streamengine_calculated_rate /var/tmp/ubicom_streamengine_calculated_rate.tmp
echo Streamengine shaper disabled: WAN speed greater than 2mbps detected
/etc/init.d/se_unload
STREAMENGINE_SHAPER_LOADED=0
else
#
# Enable shaper with optional dynamic fragmentation
#
#config_get DYN_FRAG_ENABLED streamengine qos_dyn_fragmentation
DYN_FRAG_ENABLED=$(nvram get qos_dyn_fragmentation | cut -c25- -)
/etc/init.d/se_shaper_set $DYN_FRAG_ENABLED auto
fi
fi
fi

just change the part

if [ $TX_RATE_BPS -gt 2000000 ] ; then

to some higher value. in this case 2000000 to 20000000

and then change the check in the adv_qos.asp. basically the them from 2048 to 20480.
im to lazy to boot the vm up again to post the exact code.
i will do it later. im tired and going to bed now ;)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #7 on: February 07, 2014, 01:47:15 PM »

Awesome. I think I moved it into the Archives. I know theres a DIR-645 that someone did a mod on as well for L2TP connections.

I'll give this a go and report findings as I'm on a 3Mb uplink now with my ISP.

Have a good night.  ;)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #8 on: February 07, 2014, 04:29:30 PM »

Ok so I uploaded the mod file:
It's seeing my 3Mb Uplink speed when TS is enabled and set for Automatic:
Enable Traffic Shaping :     
Automatic Uplink Speed :     
Measured Uplink Speed :   3371 kbps 

ISP speeds look good too, however the uplink test drops from 3Mb to 2.5~2.4Mb during testing. This could be that it's during peak hours now here:
Last Result:
Download Speed: 52422 kbps (6552.8 KB/sec transfer rate)
Upload Speed: 2462 kbps (307.8 KB/sec transfer rate)
‎2‎/‎7‎/‎2014‎ ‎5‎:‎26‎:‎08‎ ‎PM

Will be playing xbox tonite with 2 boxes gaming. Will see how it works.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

shm0

  • Level 2 Member
  • **
  • Posts: 51
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #9 on: February 08, 2014, 04:56:54 AM »

I have 5Mbit Upload and set the Upload Speed for QoS to 5120.
On speedtests i get around ~ 4,8 Mbit. Seems fine for me.
Some upload gets lost by overhead and maybe the qos engine is also limiting it further to have some headroom. I know from other QoS Setup that Upload limit should be set to ~90 % of the total upload speed.
Maybe the engine is doind that internally dunno.

I think your are on cable right? As you said it can be possible that on peak hours that you dont get your maxiumum speeds, cause cable is shared medium.

anyways for my quick test its running fine. lets see how it goes.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #10 on: February 08, 2014, 10:24:52 AM »

So checking again this morning, I'm still seeing the sustained uplink test kick down from 3Mb to 2.5Mb shortly before the test ends. I don't notice this on a different router thats has a DIR-645 class Traffic Shaper that supports over 2Mb speeds. So I presume the TS is doing this. I do need to test with my PC out of the QOS rule I have setup.  ::)

Last Result:
Download Speed: 52156 kbps (6519.5 KB/sec transfer rate)
Upload Speed: 2567 kbps (320.9 KB/sec transfer rate)
‎2‎/‎8‎/‎2014‎ ‎11‎:‎18‎:‎16‎ ‎AM

Over all it working good though. We played Ghosts for hours last night and didn't see any issues while both xboxes were online. OPEN NAT. Gaming was good.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

shm0

  • Level 2 Member
  • **
  • Posts: 51
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #11 on: February 08, 2014, 11:15:03 AM »

Try with only automatic classification.

for me it its going slowly from 0 to 4.8 MBits. And i have no drops on end of the test. which test did you use?

Does your ISP use some kind of bursting for upload?

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #12 on: February 08, 2014, 11:21:23 AM »

Ok will try when I get home. No on isp processing.
Mines thru the isp ao it does there own test then they automatically connect to speedtest.net and run a test there. Ill go back and run my own w speedtest.net and see.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47912
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #13 on: February 08, 2014, 02:40:19 PM »

Ok so running direct to speedtest.net I got a sustained 3Mb with out a kick down:


I presume there is something on the ISP side maybe doing something during testing. This is with my PC in a QoS rule and outside as well. Seems to work...
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

shm0

  • Level 2 Member
  • **
  • Posts: 51
Re: Firmware 1.04 QoS Mod - Finally!
« Reply #14 on: February 08, 2014, 03:30:30 PM »

okay seems looking good.

can you do some heavy uploading (ftp transfer or upload test) and check your latency at the same time?
With QoS enabled and without to compare them?

You assigned your pc a qos rule? so every traffic gets the same priority? i think this is same kind of suboptimal. maybe you should assign qos rules on port basis rather then ip basis.
« Last Edit: February 08, 2014, 03:37:02 PM by shm0 »
Logged
Pages: [1] 2 3 ... 7