• August 18, 2019, 08:24:49 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: "Failed to write directory" error in log with every backup attempt  (Read 3933 times)

scp36

  • Level 1 Member
  • *
  • Posts: 1

Hello all,
I have a DNS-320L with 2 Seagate ST4000VN000-1H41 4TB drives in RAID-1.  Whenever I try to use D-Link Sharecenter Sync to run a backup of a local hard drive on my desktop PC, it runs for a while and then fails.  The message in the log is always similar to this: "Failed to write directory \\192.168.25.25\Volume_1\G\de3c0225-9b2d-4f55-8151-c7ac05cf9188\tmp\id0."
If I look at the contents of the folder on the DNS-320L, it always seems to be failing at the same point.  I have tried deleting files on the source drive, including the last file backed up and the one after that to see if maybe there was a corrupt file.  But it just fails at some other point.  The log really isn't telling me much!  I have tried running backups from a couple of different hard drives and always have the same problem.  Anybody have any ideas?  I am including some screenshots.  Thanks!!


Logged

SimonFraser

  • Level 1 Member
  • *
  • Posts: 2
Re: "Failed to write directory" error in log with every backup attempt
« Reply #1 on: December 06, 2013, 02:59:17 PM »

Yep, exactly same issue here :(
Strange thing is, it works fine from my IPad ...

Anyone know how to sort this ?

Have rebooted the 320L and gone through the setup again, makes no difference.
« Last Edit: December 07, 2013, 01:16:16 PM by SimonFraser »
Logged

SimonFraser

  • Level 1 Member
  • *
  • Posts: 2
Re: "Failed to write directory" error in log with every backup attempt
« Reply #2 on: December 08, 2013, 11:53:45 AM »

Ah,
It's to do with permissions
I bet you tried to copy files out of the default Documents location

Set up a new folder with subfolders in the c:\new and see if that copies, works for me


So, how to switch off permission on the default documents location .... WTF they are my own files !

I failed to change the permission for my own files for copying :(


Solved the Microsoft problem by setting up a new C:\MyDocs
Short cut on the desktop so everyone can find it
Save everything, subdirectories, files, pictures, in C:\MyDocs
DLink Share Centre Synch now backs up just fine, v fast, using that :)

S

« Last Edit: December 08, 2013, 02:39:50 PM by SimonFraser »
Logged