• October 25, 2020, 06:16:33 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DNS Settings being ignored?  (Read 8479 times)

nofear_102

  • Level 1 Member
  • *
  • Posts: 7
DNS Settings being ignored?
« on: October 13, 2013, 07:07:26 AM »

Hi all, I am trying to force the use of a specific DNS server in conjunction with my local ISP which uses a dynamic IP system. I have done the following:
1. Set the primary and secondary DNS server addresses
2. Disabled "Enable DNS Relay"

The only way I can get the DNS sever settings to be acknowledged is if I set the WAN IP to static...since my IP is continaully being re-assigned this is not reasonable. I was using the same settings with my Linksys E4200 and had no issues what so ever (i.e. Dynamic ISP IP with primary and secondary DNS severs provided).

I have even tried leaving them blank and setting the DNS server information on my computer but it still fails.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS Settings being ignored?
« Reply #1 on: October 13, 2013, 10:03:01 AM »

    Link>
Welcome!
  • What Hardware version is your router? Look at sticker under router.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?
  • Are you wired or wireless connected to the router?

Have you flushed the DNS cache from all devices after the DNS was set up on the router?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?
  • What ISP Modem service link speeds UP and Down do you have?
  • Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
  • For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.

Router and Wired Configurations
Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router.
  • Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options, Advanced/QoS or Gamefuel.
  • Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
  • Enable Use Unicasting (compatibility for some ISP DHCP Servers) under Setup/Internet/Manual.
  • Turn on DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench
  • Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
  • Ensure devices are set to auto obtain an IP address.
  • If IPv6 is an option on the router, select Local Connection Only or Disable IPv6 options under Setup/IPv6.
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules. Enable IPv6 Multi-cast Streaming for routers that have a Media Server option. Disable IPv6 Multi-cast Streaming if IPv6 or Media Server is not being used.
  • Turn off WISH, and WPS under Advanced.
  • WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
  • Set current Time Zone, Date and Time. Use an NTP Server feature. Tools/Time.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

nofear_102

  • Level 1 Member
  • *
  • Posts: 7
Re: DNS Settings being ignored?
« Reply #2 on: October 14, 2013, 11:28:12 AM »

Here is the info...I tried the settings suggested below but no luck

Hardware = A1
Firmware  1.05b07
Region = Canada
Wired and Wireless

DNS Flush = Yes

ISP = MiMo
MTU is fine

Please let me know what else I can try...I have never had an issue like this in the past with other router brands.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS Settings being ignored?
« Reply #3 on: October 14, 2013, 12:24:05 PM »

  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?


Disable IPv6, set it to Local Only...

ISP = MiMo  ???
« Last Edit: October 14, 2013, 12:26:02 PM by FurryNutz »
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

nofear_102

  • Level 1 Member
  • *
  • Posts: 7
Re: DNS Settings being ignored?
« Reply #4 on: October 15, 2013, 05:02:14 AM »

MIMO technology is the same technology that cell phone providers are starting to deploy with the LTE networks. This technology allows us to stay future proof and ensure that we can always provide you the highest service possible
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS Settings being ignored?
« Reply #5 on: October 15, 2013, 07:22:37 AM »

So I presume that there is some forum of modem or LAN cable connected to the WAN port of the 865L and that your getting a public IP address on the WAN side?

What are the DNS values seen under Status/Device Info/Wan section? Default should be your ISPs DNS. Now if you turn OFF DNS relay and input different DNS into Setup/Internet/Manual, does this change the DNS values seen under Status/Device Info/Wan section? It should...
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

nofear_102

  • Level 1 Member
  • *
  • Posts: 7
Re: DNS Settings being ignored?
« Reply #6 on: October 15, 2013, 04:21:40 PM »

Yes, there is an ethernet connection to the WAN port.  I have disabled DNS relay and input the primary and secondary DNS server settings to no avail...when I set a static IP everything works, the minute I go back to dynamic the DNS settings are ignored.

As mentioned, I have tested the exact same thing with other routers and there is no issue with dynamic IP and DNS.

The odd part is that in the status section it does show the DNS settings I provided (for dynamic and static).
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS Settings being ignored?
« Reply #7 on: October 15, 2013, 04:23:55 PM »

Ok, I recommend that you phone this in and ask for level 2 or higher support from D-Link Canada. We use the same FW here however i haven't had a chance to test this on out on mine yet. Mines being used as a Bridge at the moment.

Please let us know how it goes and what they say. I hope they can figure it out...
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

nofear_102

  • Level 1 Member
  • *
  • Posts: 7
Re: DNS Settings being ignored?
« Reply #8 on: October 16, 2013, 06:11:59 PM »

O.k.

It's really weird, when I set a static IP the DNS settings I input are visible in my iPad, when I change to dynamic 2 additional DNS severs (from my ISP I am assuming) appear in addition to the 2 I input.

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS Settings being ignored?
« Reply #9 on: October 18, 2013, 07:14:59 AM »

Yes, this model router is known for showing 4 DNS on query for some reason. I've mentioned this to D-Link a while back.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!