• September 25, 2020, 01:59:02 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Enable Remote Management / Internet Access to 192.168.0.1 Admin Settings  (Read 78273 times)

martyb

  • Level 1 Member
  • *
  • Posts: 9

I'm really enjoying my DIR-868L.  Currently using the router in PPPoE mode with a Motorola 3360 DSL modem that is set to bridged mode.  Internet is working fine on all hosts within the LAN.

I have configured remote access of a QNAP NAS on the LAN via no-ip.com by entering a single rule under ADVANCED>PORT FORWARDING to forward calls to 192.168.0.108 (NAS address on LAN) with TCP 80,8080.  When I enter host name configured via no-ip.com from a remote location, I go straight to the Login Page of my NAS - so all remote access to a NAS device on the LAN works great...  (All that said to demonstrate remote access to a device on the LAN is working through the router.)

After successfully registering the router with mydlink service, I can login via https://www.mydlink.com/entrance and view limited info on the router, but not the complete router configuration pages available through local 192.168.0.1... 

What I would rather do is access the DIR-868L's admin page at the local 192.168.0.1, but from a remote site, just like I can do with the NAS above... But I am having no luck.

If I remove the rule to port forward, (so that the request goes straight to 192.168.0.1 instead of 192.168.0.108) an attempt to connect from remote times out.  If I try to modify the rule from 192.168.0.108 to 192.168.0.1, I receive a popup dialog box "The IP Address could not be the same as LAN IP Address."

If I go to TOOLS>ADMIN and check "Enable Remote Management", I receive a popup dialog box "The remote admin port has been used in the port forwarding function."  If I remove the 8080 from the port forwarding rule, and enable remote management, requests from remote time out. 

If I check Use HTTPS, and attempt to access from remote via myname.noip.com:8090, the requests from remote time out as well....

This may be unrelated - but I have attempted over and over to make TOOLS>DYNAMIC DNS function/connect with my dlinkddns.com account, but it ALWAYS says Status: Disconnected.  As a result, I let my NAS's DDNS function update my IP via no-ip.  (I'm not sure if you MUST use a dlinkddns.com account via the router to access remote admin page on the router itself?)

I'm sure there is something very goofy I am overlooking here.  Any ideas anybody?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49209
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Remote Management page is only accessible via a public IP address from the WAN side for security reasons. The LAN side is tied only to the 192.168.0.1 router default address or what ever the default address is on the LAN side.

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

martyb

  • Level 1 Member
  • *
  • Posts: 9

FurryNutz- Thank you again for the reply!

OK, so if my public IP address on the WAN connection to the router is 123.45.67.8, I should be able to enter 123.45.67.8:8090 (for HTTPS access) from a remote Internet connection and be taken to my router's web-based admin page, right?  But the request times out...


Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49209
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Yes if the router has a public IP address and you've enabled RM on the router and your ISP modem doesn't have any NAT on it, you should bet the routers web page cleanly.

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

martyb

  • Level 1 Member
  • *
  • Posts: 9

FurryNutz - the Motorola 3360 (ADSL modem connected to the WAN port on the DIR-868L) is in bridged mode - so all NAT should be within the DIR-868L.

The interesting thing is with the port forwarding rule checked, I go directly to the NAS @ 192.168.0.108...  If I uncheck the rule, requests to my WAN IP should go directly to the router @ 192.168.0.1 (I assume) - but instead, requests time out. 

Enable Remote Access box is checked...  I've tried adding :8080 and :8090 to the WAN IP/no-ip address - and nothing seems to work.  Any other ideas?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49209
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Are you using DNS Relay by chance? ON or OFF? or DDNS?

I don't use DNS Relay or DDNS and I can get to my routers web page from here at work...granted my 868L isn't online currently.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

martyb

  • Level 1 Member
  • *
  • Posts: 9

Doing all of this from a new DIR-868L in stock form/settings (other than the single port forwarding rule to reach the NAS and the PPPoE login settings to reach the modem-ADSL service)... 

I checked SETUP>NETWORK SETTINGS - and noticed "Enable DNS Relay" was indeed checked.  I see the manual states "Uncheck the box to transfer the DNS server information from your ISP to your computers. If checked, your computers will use the router for a DNS server."   This should be unchecked for what I am attempting to do, correct?

I unchecked and tried again with the same results - but the no-ip.com forwarding service will still take me to the NAS on 192.168.0.108 if the port forward rule is checked.  Without it checked (and presumably changing an outside connection attempt from 192.168.0.108 to 192.168.0.1) I get a time out when attempting remote.

I also registered a name with dlinkddns.com - and tried that.  Even though I can never get the status to go to "Connect" at TOOLS>DYNAMIC DNS, I get redirected to my NAS login page (from a remote location) when having the "IP in DNS" setting set to 192.168.0.108 - but a timeout when it is set to 192.168.0.1 (trying to reach admin signin page on router.)

Interestingly enough, when I use the URL registered with either dlinkddns.com or no-ip.com from a PC within the LAN, I go straight to the router's login page.  However, from a remote location, I still get a timeout unless I forward it to the NAS at 192.168.0.108...  Really odd I can not access 192.168.0.1 from remote, but I can access 192.168.0.108 with the port forwarding....   I'm overlooking something really simple here.....
 
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49209
  • D-Link Global Forum Moderator
    • Router Troubleshooting

So with out setting up any PF or NAS configuration and just using default ISP DNS, DNS Relay ON, Remote Management enabled, HTTPS or up to you, you should be able to get to the routers web page remotely by using HTTP://public ip address on router:port number from the remote location.

Ensure any 3rd party security SW is disabled temporarily while testing this on the remote PC.

What ISP Modem Mfr. and model # do you have?
What FW version is currently loaded?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

martyb

  • Level 1 Member
  • *
  • Posts: 9


Using a Motorola 3360 Modem - P/N: 581211-001-00 to connect to AT&T ADSL service.  (Setup in bridged mode...)
DIR-868L Hardware V A1, Firmware V 1.02

Testing this from work.  When I get home tonight I will do a hard reset on the router and try again.... 
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49209
  • D-Link Global Forum Moderator
    • Router Troubleshooting

I would also install Teamviewer at home so you can access the router or anything else as a work around if something happens.

Keep us posted.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

martyb

  • Level 1 Member
  • *
  • Posts: 9
Re: Enable Remote Management / Internet Access to 192.168.0.1 Admin Settings
« Reply #10 on: August 16, 2013, 12:02:31 PM »

Yeah - that is exactly what I am doing.  Have a PC at home with Teamviewer running so I can access the router "locally @192.168.0.1" through the PC with teamviewer installed.  Using teamviewer at work to adjust settings on home router and then attempting regular http internet connection from work to the router at home.

My goal is to access router from remote without a dedicated PC on the LAN at home...  I've figured out access to the QNAP NAS's http login/admin pages.... just need to get into the router from remote and I'll be set.

Will hard reset router and report back.
 
Logged

martyb

  • Level 1 Member
  • *
  • Posts: 9
Re: Enable Remote Management / Internet Access to 192.168.0.1 Admin Settings
« Reply #11 on: August 17, 2013, 01:27:58 PM »

Whats going on FurryNutz?  I found my problem - and believe the solution being posted here will save someone else a lot of troubleshooting time.

I tested and tested and found out it was the specified PORT (or lack of specified port) that was stopping the connection from remote.  

Entering http://{mywanipaddress} or http://myname.mydnsprovider.com resulted in a 404 or timeout.  I attempted to specify :8090 for https or :8080 with the same result.

It was only after I changed the remote admin port within the router to something OTHER than the default 8080 or 8090 and also specifying that same port number in the URL that I was able to connect via remote.  So, in TOOLS>ADMIN I checked "Enable Remote Management" and then changed the Remote Admin Port from the default 8080 to something odd (like 10080, etc.) and then specified that same port number after the URL (http://{mywanipaddress}:10080 or http://myname.mydnsprovider.com:10080) and was taken directly to the login page for the router from a remote connection location!!!

This single change was all that it took for remote access on a hard-reset (factory defaults) DIR-868L with a bridged ADSL modem... No other Port Forwarding, Firewall changes, etc. needed.  I'm rockin and rollin now!


« Last Edit: August 17, 2013, 01:29:35 PM by martyb »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49209
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Enable Remote Management / Internet Access to 192.168.0.1 Admin Settings
« Reply #12 on: August 17, 2013, 02:05:26 PM »

Awesome info man. Thanks for the information and taking the time to find the solution. We'll keep this in the Archive for sure.

Enjoy and have a great weekend.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!