• August 13, 2020, 05:33:49 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Cannot view playback after latest Firmware upgrade  (Read 2165 times)


  • Level 1 Member
  • *
  • Posts: 1
Cannot view playback after latest Firmware upgrade
« on: May 12, 2013, 10:58:52 AM »

I have a DCS-942L.  Everything was working fine on my setup until I upgraded the firmware the other day. In the mydlink.com website when I logged in that day, it stated a firmware upgraded was needed.  So I clicked on upgrade, let it run its thing and then tried to view the playback and now the thumbnails are just black and when I click on one, it looks like it is loading but then shows the quicktime icon with a question mark over it.  I upgraded my Quicktime component and that didn't fix it either.  So I went into advanced settings, downloaded the new firmware upgrade from there by saving the zip file and uploading it via the advanced settings website, and still nothing.  I have another camera, same setup, that I have not upgraded firmware on yet and that playback is working fine.  Any suggestions?


  • Level 2 Member
  • **
  • Posts: 26
Re: Cannot view playback after latest Firmware upgrade
« Reply #1 on: June 16, 2013, 02:01:14 PM »

Can you view playback on any device?  I lost playback on my phone and tablet, but my PC playback still worked.  I reformatted my SD card, and was able to get phone/tablet playback working again.
DLINK DCS-942L & DCS-2330L, Asus RT-N66U router