• August 20, 2019, 03:55:16 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DNS-315 connection problems  (Read 5119 times)

Hunsidian

  • Level 1 Member
  • *
  • Posts: 7
DNS-315 connection problems
« on: April 23, 2013, 12:17:49 PM »

Hello!

I have bought a D-Link DNS-315 NAS server a few months back.
After I installed it, it worked good until now.
Now, when I want to connect to the file server or the printer server features, Windows says that it can not connect to the destination.
When I write the IP to the browser, the management site is shown.
Tried restarting computer, router and NAS as well, and the management site shows everything is good (printer connected, has no errors with HDD).
When I used the Windows troubleshooter, it came up with this:
Quote
The remote device or resource won't accept the connection
 
The device or resource (192.168.1.122) is not set up to accept connections on port "The File and printer sharing (SMB)".

Any idea on solving this problem?

Logged

d3pr3

  • Level 1 Member
  • *
  • Posts: 1
Re: DNS-315 connection problems
« Reply #1 on: September 30, 2013, 02:17:53 PM »

I have the same problem,
have you solved?
Logged

Hunsidian

  • Level 1 Member
  • *
  • Posts: 7
Re: DNS-315 connection problems
« Reply #2 on: September 30, 2013, 11:06:47 PM »

Nope.

Only a few additional information:
On Ubuntu client, it does not happen (I can't reach it on Windows, but I can on Ubuntu)
I have set up an FTP server on the NAS, I can reach the server anytime (even when the "normal" connection is not working).
But for printing, I still have to do the restarting NAS and praying that it works good routine a few times...
Logged

ivan

  • Level 8 Member
  • ***
  • Posts: 1441
Re: DNS-315 connection problems
« Reply #3 on: October 01, 2013, 09:32:30 AM »

From your additional information I have a couple of questions.

1)  What version of windows?

2)  Have you, or windows update, changed anything?

Since you have no problems with Ubuntu it gives a very strong indication that windows is the problem.  Maybe something has changed in the firewall settings or, if win 7, access permissions may have been changed.

In many cases the sort of message you got tends to be a red herring meaning the remote device isn't responding because windows isn't contacting it.
Logged

Hunsidian

  • Level 1 Member
  • *
  • Posts: 7
Re: DNS-315 connection problems
« Reply #4 on: October 01, 2013, 10:38:46 AM »

Yeah, I thought that the problem is with the Windows (most likely it is), but I can't think of anything that can do this...
1) The problem is from multiple computers (2 Win7, 1 WinXP)
2) The restarting of the NAS server usually solves it after a few (1-2) retries, without changing anything on the Windows - and it solves this problem on all of the computers

btw no, I haven't changed anything, for the Windows Update, I can't guarantee, but for the WinXP comp, that has the same problems, I'm sure that it's settings are the same (since WinXP is only getting security updates AFAIK, and even those are rarely released)
Logged

ivan

  • Level 8 Member
  • ***
  • Posts: 1441
Re: DNS-315 connection problems
« Reply #5 on: October 01, 2013, 04:23:53 PM »

Just a thought, you may have hit the master browser problem that sometimes finds its way into predominately windows networks.

It might help to read through this thread: http://forums.dlink.com/index.php?topic=46232.0
Logged