• October 14, 2019, 04:53:46 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: How I fixed my sdcard issues  (Read 1636 times)

sark666

  • Level 1 Member
  • *
  • Posts: 18
How I fixed my sdcard issues
« on: March 24, 2013, 10:35:58 AM »

Just got this camera and I'm very pleased so far.  I came here because I had sdcard issues and people were saying to do a factory reset and potentially reapply the firmware etc.   I didn't want to go through all that after I had it configured and tried other methods.

I was previously using this sdcard (16 gig forget the brand I think class 4) on a windows machine and on two android devices for storage, but I couldn't get the camera to recognize it.  It would say no sdcard in the unit or sdcard is not writeable or something to that effect.

I installed the latest version of EaseUS partition master (or use your favourite partition editor as long as it will show external devices) and my 16 gig card actually had two partitions, one only about 16 megs or something, not sure if android created that.

Anyway, wiped the partitions,  reformatted to fat32, but the camera still didn't recognize it.  What got it working was I had to turn off sd recording first and then sd management would let me format the sd card.  Prior to that the format option was greyed out.

Anyway, took about 5 minutes and it's working without a factory reset.  I did upgrade the firmware prior to trying this, but the firmware didn't solve it.

Also I feel I should put a disclaimer, partition software is pretty easy to use but make sure you are selecting your sdcard and not your C drive or other harddrive, as you can completely wipe your OS if you are not careful.
« Last Edit: March 24, 2013, 10:45:21 AM by sark666 »
Logged

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2110
Re: How I fixed my sdcard issues
« Reply #1 on: March 24, 2013, 10:43:02 PM »



Anyway, wiped the partitions,  reformatted to fat32, but the camera still didn't recognize it.  What got it working was I had to turn off sd recording first and then sd management would let me format the sd card.  Prior to that the format option was greyed out.


Thanks!

Sounds reasonable...
Logged