• October 29, 2020, 04:39:14 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DIR-601 Virtual Server for wire and wireless connection  (Read 3126 times)

dir601-u1

  • Level 1 Member
  • *
  • Posts: 1
DIR-601 Virtual Server for wire and wireless connection
« on: November 30, 2012, 09:09:01 AM »

I have DIR-601 wireless router with two computers connected:  Server (192.168.1.2) and Client (192.168.1.3 on Ethernet Port and 192.168.1.4 on Wireless)

I also use dlinkddns.com and my router's public IP is mapped as abc.dlinkddns.com.

In the router Virtual Server section, it is configured as:
Public Port: 3389   (for Remote Desktop)
Private Port: 3389
IP Address:  192.168.1.2  (server's IP)

I am expecting this to allow the client to access the server via windows Remote Desktop.

The current situation is:
- When wireless is on, the client can access the server's Remote Desktop
- When wireless is off and client is connected by wired Ethernet, the client cannot connect to the server's remote desktop. After timeout, the error msg is "Remote Desktop can't connect to the remote computer for one of these reasons: ...".
- When the client is in another network, it can connect to the server through the Internet.

What can be the problem?
I am sure it's not the client's problem because it can access via wireless or remotely from another network.
It's not the router's virtual server config problem for the same reasons.
Will it be a bug in the router? (hardware version: B1, firmware version: 2.00NA).






Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-601 Virtual Server for wire and wireless connection
« Reply #1 on: November 30, 2012, 09:17:08 AM »

When you mean wireless is ON and OFF, is this the wireless adapter connection on the ROUTER or the Client PC? If it's the client PC, I presume that you should set up a reserved IP address for the wired and wireless connection as each on of these connection modes should have a different IP address.

How are you entering in the server address in RDP? I haven't seen this before however I don't have the 601 any more. Usually VS RDP isn't needed for any LAN side connections. I use it on my network and don't have any RDP settings configured. I just input the IP address of the PC I have it enabled on and it goes. Try disabling your VS settings temporarily and see if you can just connect between the server and client.

Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Try Disabling SPI firewall temporarily as a test.

Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.

What ISP Service do you have? Cable or DSL?
What ISP Modem do you have? Stand Alone or built in router?
What ISP Modem make and model do you have?
« Last Edit: November 30, 2012, 09:21:08 AM by FurryNutz »
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!