• May 24, 2020, 06:47:16 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2

Author Topic: Web server behind DSL-520B  (Read 24607 times)

JacksBack

  • Level 1 Member
  • *
  • Posts: 8
Web server behind DSL-520B
« on: November 12, 2012, 06:48:07 PM »




Hello,

I'm trying to configure our new DSL-520B router to allow one of the computers behind it to be a web server. We'll handle DNS later - at the moment, if our IP address is 206.123.234.123, I'd like to be able to

http://206.123.234.123

and get to the server. I can't - every time I do this from a machine behind the DSL-520B, I get the log-in window for the router. A machine outside the router can't connect at all.

We have a virtual server setup configured like this:

Web Server (HTTP)    80    80    TCP    80    80    192.168.2.11    206.123.234.123    disable

(The machine that's being a web server is running Apache, and it's configured correctly. If I http://192.168.2.11:8080 on a machine behind the DSL-520B, I can browse the pages on our local web server.)

I'm pretty sure I've missed something fairly obvious - while we have a fair bit of expertise with net servers, this is the first time we've tried setting up something like this.

Can anyone point me to some instructions or suggest what we need to do to make this work?

Thanks.

::Jack



Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Web server behind DSL-520B
« Reply #1 on: November 12, 2012, 06:56:08 PM »

You need to contact your ISP service and make sure that they allow other Web Servers on there systems. Sometimes ISP block port 80 from allowing web servers from being accessed which we can configure anything around. Using Virtual server should be used however if the ports are closed on the ISP side, it won't work. Please verify with the ISP this this is allowed.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Web server behind DSL-520B
« Reply #2 on: November 12, 2012, 07:54:26 PM »

Might try the following:
http://forums.dlink.com/index.php?topic=13539.0
Not sure if it will help or not.

Review the following:
http://forums.dlink.com/index.php?topic=40720.0
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

JacksBack

  • Level 1 Member
  • *
  • Posts: 8
Re: Web server behind DSL-520B
« Reply #3 on: November 13, 2012, 09:04:44 PM »


I hadn't thought of the ISP blocking ports.

I contacted them - they're fine with our hanging a web server on the DSL connection, and they assure me that all ports are unblocked.

Where should we look next?

::Jack
Logged

Grem

  • Level 1 Member
  • *
  • Posts: 20
  • regular citizen
Re: Web server behind DSL-520B
« Reply #4 on: November 13, 2012, 10:16:10 PM »

JacksBack,
Probably you forgot to turn off all your modem wan port Access Control Services. Its under Management menu.

Your web server is 192.168.2.11:8080  ???
Code: [Select]
Web Server (HTTP)    80    80    TCP    80    80    192.168.2.11    206.123.234.123    disablebut you trying to forward external 80 to internal 80 not 8080

1. Turn off wan port Access Control Services. And don't forget to change all default passwords  ;)
2.  I don't know how your "virtual server" or "forwarding menu" looks like on DSL-520B (It's another local variant of DSL320 or DSL2500 )
Code: [Select]
Server Name External Port Start External Port End Protocol Internal Port Start Internal Port End Server IP Address
Web Server (HTTP) 80 80 TCP 8080 8080 192.168.2.11
« Last Edit: November 13, 2012, 10:46:18 PM by Grem »
Logged

JacksBack

  • Level 1 Member
  • *
  • Posts: 8
Re: Web server behind DSL-520B
« Reply #5 on: November 14, 2012, 08:37:55 AM »


Hello again,

Under Access Control -- Services there's a list with FTP, HTTP, ICMP, SNMP, TELNET and TFTP. They're all enabled for LAN and all disabled for WAN. Is this correct?

When I set up the virtual server for HTTP, a message appeared that said "Since port 80 is used, the DSL router WEB server port will be moved to 8080." I took this to mean that any client outside the router attempting to access the server behind the router through port 80 would have the packets translated by the router to port 8080, and as such, I had the web server listen on port 8080. Should we handle this differently?

This is what our virtual server entry looks like at the moment (if I've used the Insert Image feature here correctly.)



Thanks for all your help so far.

::Jack


Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Web server behind DSL-520B
« Reply #6 on: November 14, 2012, 08:51:53 AM »

I believe you are correct as an inbound traffic on the public port 80 would need to be translated to a different port such as 8080 which is a valid port for anything internal. Port 80 is a WAN side port and generally not translated on the LAN side. I most cases it doesn't even need any sort of forwarding as it's a main port for most HTTP traffic. I believe the LAN side port could be any port number value just as long as the client side server and SW is looking at the specified LAN side port and is configured correctly in the router. So I presume you should change the Internal Port Start and End to 8080.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

JacksBack

  • Level 1 Member
  • *
  • Posts: 8
Re: Web server behind DSL-520B
« Reply #7 on: November 14, 2012, 09:08:08 AM »


If I set the Internal Port Start and Internal Port End to 8080 (rather than 80), nothing changes.

Attempting to access the page normally, http://216.123.238.123 , gets me to the login window for the router. Attempting to access it with the port number, http://216.123.238.123:8080, gets a "Firefox can't establish a connection to the server" screen.

In that the eventual users of the web server are going to be using conventional URLs, such as http://www.myserver.com , rather than http://www.myserver.com:8080 , this is going to need to work without the router wanting to respond to HTTP requests on the default port of 80 (by asking for a router login password.)

What can I try next?

::Jack

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Web server behind DSL-520B
« Reply #8 on: November 14, 2012, 09:26:37 AM »

Attemping to use that same IP address I'm getting a VM Portal 5 You must use the View Client to access this Connection Server

To connect, start the View Client and enter https://216.123.238.123 as the server URL. You can open this page in Internet Explorer to install or automatically start the View Client.

Alternatively, use the links below to download a suitable View Client installer:

Is this correct?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

JacksBack

  • Level 1 Member
  • *
  • Posts: 8
Re: Web server behind DSL-520B
« Reply #9 on: November 14, 2012, 09:38:09 AM »


Sorry - my bad. That's not our real IP address, this being a public forum and all. I can e-mail you the real one if it would help. (If so, let me know the address to send it to.)

::Jack

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Web server behind DSL-520B
« Reply #10 on: November 14, 2012, 09:42:35 AM »

PM me the real one...
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

JacksBack

  • Level 1 Member
  • *
  • Posts: 8
Re: Web server behind DSL-520B
« Reply #11 on: November 14, 2012, 09:46:53 AM »



I'm so old-tech - we don't PM.

I sent it to the e-mail address in your profile. Hope this works.

::Jack

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Web server behind DSL-520B
« Reply #12 on: November 14, 2012, 10:06:26 AM »

I'm old too however PM is quicker here. Hehe.

Ya, my Opera is not getting anything here at work.
I wonder if you set Internal Start port to 0 and End to 65535? Try this on both WAN and LAN ? Not sure if this will work.

Are there any firewall settings?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

JacksBack

  • Level 1 Member
  • *
  • Posts: 8
Re: Web server behind DSL-520B
« Reply #13 on: November 14, 2012, 10:20:19 AM »


Tried setting the ports from 1 to 65535 (port zero being invalid, the router says.) Nothing changed.

I don't see any firewall settings in the router, unless they're called something different. It's not a firewall issue in the web server, as (a) the problem doesn't go away when the web server's firewall is disabled and (b) the network monitor running on the web server doesn't show any packets getting that far when I try to access the web server through the external IP address.

I suspect that the problem involves persuading the router not to interpret HTTP traffic sent to the external IP address as an attempt to access the router's web interface, but rather, to pass these packet through to our internal network. Nothing in the configuration for the router seems to address this, but I could be missing the obvious.

::Jack

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Web server behind DSL-520B
« Reply #14 on: November 14, 2012, 10:53:38 AM »

Ya, I wish I had a bit more experience on DSL model modem.

You should phone contact level 2 or 3 Dlink support and see if we are missing something. Seems like it's something simple and your just about there.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!
Pages: [1] 2