• July 20, 2019, 04:54:07 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Playback video not working in Firefox  (Read 14098 times)

MichaelH1

  • Level 1 Member
  • *
  • Posts: 20
Playback video not working in Firefox
« on: September 02, 2012, 10:03:54 AM »

I'm using a DCS-942L camera and Mozilla Firefox.  When I upgraded the camera firmware to 1.12 I see there is now a new video playback function on the mydlink website.  This is great, but the video doesn't play in my Mozilla Firefox browser.  There is just a black box, with text "Cannot see the video?  Please download and install the plug-in." underneath.  I tried clicking on this, and it runs wmpfirefoxplubin.exe, but there is no change.

My Live View streaming video works fine, and the feature also works fine in Internet Explorer and Chrome.  It's just Firefox (my main browser, for other reasons) that has an issue.  Also, if I go to the Advanced Setting page on the camera, to SD Management, I can download and open a video file and it works well.  But the new mydlink playback is much more convenient.

Anyone have any suggestions?

Thanks!

Mike
Logged

MichaelH1

  • Level 1 Member
  • *
  • Posts: 20
Re: Playback video not working in Firefox
« Reply #1 on: November 29, 2012, 12:04:13 PM »

I resolved the problem.

I disabled the VLC media player in Firefox plugins, and now the video plays correctly.
Logged

interconnect

  • Level 1 Member
  • *
  • Posts: 15
Re: Playback video not working in Firefox
« Reply #2 on: December 28, 2012, 11:35:09 AM »

I have this same issue when trying to view video saved to my DCS-942L's MicroSD card via the MyDlink website.  I am not able to view saved video, although I am however able to view live video.  When trying to view saved video, I only hear sound, no video.  I installed the required plugin for Firefox and it still does not work.  I also tried disabling the VLC plugin in Firefox and it did not work.  Additionally, I could not get it to work in Chrome 23, IE 8 and Firefox 17.
Logged

graniteman

  • Level 1 Member
  • *
  • Posts: 1
Re: Playback video not working in Firefox
« Reply #3 on: February 04, 2013, 10:36:24 AM »

I'm having the exact same problem as interconnect with my DCS-942L  very frustrating :( Hopefully I can find a solution. 
Logged

happyhere

  • Level 3 Member
  • ***
  • Posts: 173
Re: Playback video not working in Firefox
« Reply #4 on: February 06, 2013, 09:38:44 PM »

the latest version of Firefox disables Java, happened to me this week.

fix is to download the latest Java Patch.  then mine is ok
Logged

JavaLawyer

  • BETA Tester
  • Level 15 Member
  • *
  • Posts: 12190
  • D-Link Global Forum Moderator
    • FoundFootageCritic
Re: Playback video not working in Firefox
« Reply #5 on: February 07, 2013, 05:16:24 AM »

the latest version of Firefox disables Java, happened to me this week.

fix is to download the latest Java Patch.  then mine is ok

The latest Java patch corrected the issue on my FF browsers as well.
Logged
Find answers here: D-Link ShareCenter FAQ I D-Link Network Camera FAQ
There's no such thing as too many backups FFC