The Graveyard - Products No Longer Supported > DSM-510

How do I update?

<< < (2/2)

JavaLawyer:
Try using a different USB storage device. As a last resort, you could could try resetting the DSM-510 to the factory default settings prior to trying to upload the latest firmware.

deewhy:
Dunno what's wrong with the piece of s***! Tried 2 different USB sticks, formatted in FAT and NTFS. Reset to factory default. Tried all of the above and it still doesn't find an update.
It's going in eBay!

FurryNutz:
Have you contacted DLink about this? Maybe RMA  ???

JavaLawyer:
Before you throw in the towel, is the firmware file you are using for the UK or another region? I see from your member profile that you are from the UK. Firmware from other regions may not be compatible with your DSM-510.

If it's any consolation, only the following changes to the firmware were added since your current version 1.06 and the latest version 1.08 (Europe):

[*]Removed the Intel Viiv Zone from the home page.
[*]Now Skips Intel Viiv Express Setup page and goes directly to Options/Network Settings Page.
[*]Fixed playback issues for some problem DivX files.
[/list]

If none of these fixes applies you, then there really is no need to update. Since the product was phased out in 2009, future firmware updates are unlikely.

Sorry we couldn't be of more help.
Best of luck.

Navigation

[0] Message Index

[*] Previous page

Go to full version