• November 21, 2019, 03:25:40 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: [BUG] Email Notifications are sent to the Sender instead of Recipient  (Read 8157 times)

hilaireg

  • Level 3 Member
  • ***
  • Posts: 332

Hi Folks,

There appears to be an issue with the Email Notification feature.

Email Settings

Enable Email Notification = Checked

From Email Address = sysmail@mydomainname.com  *
To Email Address = myusername@mydomainname.com *
SMTP Server Address = smtp.myisp.com
SMTP Server Port = 25

Enable Authentication = Unchecked

On Log Full = Checked
On Schedule = Checked

Schedule = ~00:01 - ~00:59
Details = Sun Mon Tue Wed Thu Fri Sat



* actual email addresses where changed to avoid spam


The above configuration behaved as expected in the DGL-4100.


Observations

  • Rebooting the DIR-857 initiates an Email Notification which is received.  The email that is received provides the sender address (sysmail@mydomainname.com), subject line, and log contents, but the recipient (myusername@mydomainname.com) is empty/blank.
  • Subsequent Email Notification using the Email Now button under Logs are never recieved as they are being sent to email address of the sender (sysmail@mydomainname.com) instead of the recipient (myusername@mydomainname.com).


I can provide the full router logs as proof if desired; I won't paste them here as they contain IP/Email information that would likely end up in enemy spambot hands.  :)

Cheers,
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47921
  • D-Link Global Forum Moderator
    • Router Troubleshooting

I've set up my email notifications just now. My ISP uses Google as a 3rd party email server so our settings use google settings. After setting up the 857 I looked at the logs:
Jun 5 10:36:43  SMTP (Email) server pop.gmail.com is at IP address ##.##.###.###:465 
Jun 5 10:35:43  SMTP (Email) server pop.gmail.com is at IP address ##.##.###.###:465 
Jun 5 10:34:43  SMTP (Email) server pop.gmail.com is at IP address ##.##.###.###:465 
Jun 5 10:33:43  SMTP (Email) server pop.gmail.com is at IP address ##.##.###.###:465 

Well see if I get any logs sent to my netscape web email acct as i did with my other routers.  :-\
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

hilaireg

  • Level 3 Member
  • ***
  • Posts: 332

Thanks,

I see the same entry in the log as well:

SMTP (Email) server smtp.[myisp].com is at IP address ##.##.###.###:25


Quick tests:

- Reboot router, should send an email with Sender, Subject, Body, no Recipient
- Trigger Email Now, should receive an email - log will indicate whom it was sent to
- Wait for schedule to occur, should receive an email - log will indicate whom it was sent to


The recipient specified never receives the email in the case of the last two points.


Cheers,
« Last Edit: June 05, 2012, 08:51:30 AM by hilaireg »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47921
  • D-Link Global Forum Moderator
    • Router Troubleshooting

I can't seem to get my ISP or a web based SMTP to work with this router. Not sure if my format entries are correct or what. I presume they are has I'm using the same information I see on my phone and I know my phone works. I wish my ISP hadn't switched to google.  >:( I hope to have a couple other people check this out. One has said he got his to work using AOL acct information. I tried and could not.  :-\
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

hilaireg

  • Level 3 Member
  • ***
  • Posts: 332

You've likely configured the device correctly.

Since the Email Notification is outbound, the SMTP server of the ISP you're with typically needs to be configured as the outbound SMTP server as most ISP block open relay.  My ISP doesn't require authentication to their SMTP server when I'm on their network - i.e. using an IP Address from their network.  When I'm outside their network, I require authentication.

In short, if you can send email from one of your internal mail clients (Outlook, Eudora, etc.), configuring your router with the same settings should yield the same results.  In short, possible scenarios:

Scenario 1:
FROM: DIR857@myisp.com
TO: myemailaddy@myisp.com
SMTP: smtp.myisp.com
PORT: 25
Authentication: Unchecked

Scenario 2:
FROM: DIR857@myisp.com
TO: myemailaddy@myisp.com
SMTP: smtp.myisp.com
PORT: 25
Authentication: Checked

SMTP Authentication: username
SMTP Password: usernamepassword


Reboot the router, you should receive an email from the DIR-857.  Scheduled email or email now will produce no result as it is being sent to the FROM email address as indicated in the log.

Note that the FROM address doesn't actually have to be a "real" email address but you can configure it with a different "real" address (ex: hotmail) to confirm the behaviour.

Cheers,
« Last Edit: June 05, 2012, 04:31:14 PM by hilaireg »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47921
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Seems like this is happening on my 657 as well. I'll need to check my 645 too.  :'(
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47921
  • D-Link Global Forum Moderator
    • Router Troubleshooting

Been wondering if these routers are handling ISP email SSL/TLS authentication protocols correctly.  ???

I remember before my ISP changed to google, they didn't use SSL/TLS, google does with our ISP now. I had a working router last year with my ISP before they changed. Possible there is a SSL/TLS issue here?  ???

I'll try my 4500 or 825 soon and see if they exhibit the same thing.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JavaLawyer

  • BETA Tester
  • Level 15 Member
  • *
  • Posts: 12190
  • D-Link Global Forum Moderator
    • FoundFootageCritic

I'm also inclined to think that this issue is related to SSL/TLS handling. Email notifications work as expected on my D-Link DCS-932L network camera (using AOL SMTP), while the same email settings fail on my DIR-857. The primary difference between the and DCS-932L and DIR-857 web interface email notification setup page is that the DCS-932L includes settings for SSL/TLS, while the DIR-857 does not.

D-Link DCS-932L Network Camera - FW web interface Email Settings Page

D-Link DIR-857 - FW web interface Email Settings Page
« Last Edit: June 07, 2012, 07:48:56 AM by JavaLawyer »
Logged
Find answers here: D-Link ShareCenter FAQ I D-Link Network Camera FAQ
There's no such thing as too many backups FFC

hilaireg

  • Level 3 Member
  • ***
  • Posts: 332

Agree that there should be addtional options to handle SSL/TLS.  At the moment however, I'd simply be happy with having:

  • the recipient receiving emails instead of having to make the sender email address the recipient email address
  • the email message adhere to standards - i.e. sender, recipient, subject, and body


Ideally, it would be nice to be able to customize the subject line as well ... for example:

"Logs from DIR-857" %DATE% - %TIME%"

etc.
Logged

Burgos

  • Level 1 Member
  • *
  • Posts: 2

I have a cablevision email account that uses no security other than password and its seems to work fine. I'm able send emails from the Dlink-857 to the cablevision email without any problems. I had the same issue with my DIR-655. The is due to the lack of a option in the DIR Series email section to add SSL/TLS option like the previous poster listed DCS932L.  Whenever I try to setup any of my other 3 email accounts which use SSL/TLS I never receive the email.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47921
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: [BUG] Email Notifications are sent to the Sender instead of Recipient
« Reply #10 on: June 10, 2012, 04:48:59 PM »

Thanks for the feedback on this. Seems that ISP email with ssl/tls protocols are hosing up some router emails. Dlink has been notified of this. This info will help. Thank you.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting