• February 25, 2020, 11:37:36 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DSL-2740R Port Forward not working  (Read 10029 times)

Retro~Burn

  • Level 1 Member
  • *
  • Posts: 7
DSL-2740R Port Forward not working
« on: May 23, 2012, 12:16:51 PM »

I want to use my machine as a Minecraft server. Here's my port forwarding menu:



The port number that's needed is 25565. I've tried port forwarding TCP and UDP separately, but when I input the details and click apply for the second one (either TCP or UDP of course). I receive a message that says "Invalid !! Same NAT rule already existed" (sic). In the Private I.P box. I've used the above LAN I.P in addition to my external I.P addres but to no avail. I've also tried other LAN 192.168.1.# IPs but they also don't work. Could it be another setting that I haven't considered? I tried disabling UpnP in case that had something to do with it, but it didn't change anything and I don't see how it would interfere anyway.

Any suggestions would be much appreciated.

Thank you.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48383
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2740R Port Forward not working
« Reply #1 on: May 23, 2012, 12:23:55 PM »

Try inputting the IP address of the PC that is the MC server. Then try using Start port 0 and End port 65535 to see if this works?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Retro~Burn

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2740R Port Forward not working
« Reply #2 on: May 23, 2012, 12:31:15 PM »

No it's still doesn't work Furry.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48383
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2740R Port Forward not working
« Reply #3 on: May 23, 2012, 12:33:58 PM »

What are your firewall settings set for now?
Try using the DMZ and see if this works?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Retro~Burn

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2740R Port Forward not working
« Reply #4 on: May 23, 2012, 12:38:41 PM »

Firewall settings:

Enable Firewall : [unchecked]
Enable SPI :       [checked]   
Enable ALG :      [checked]

I tried putting my machine into the DMZ but it still doesn't work.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48383
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2740R Port Forward not working
« Reply #5 on: May 23, 2012, 12:53:33 PM »

Have you reserved all IP addresses for each PC or device on the modems DHCP server settings? Make sure all PCs are set up for auto-obtain under there networking properties.

Is this your main modem and router? Any chance you could bridge this modem and use a external router such as a DIR-645 or something similar? Not sure if this is a configuration issue or a problem with the modem. Yes It should be working however not sure what the issue is here as I don't have DSL and use cable with a stand alone modem and a external router like the DIR-645.

Where are you located?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Retro~Burn

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2740R Port Forward not working
« Reply #6 on: May 23, 2012, 01:10:13 PM »

No, they're all dynamic addresses. In the DCHP section, it says something about a 'lease' time? Which I think is 24 hours. I gather after that time, the DCHP server on the router re-assigns the IP addresses for each machine/device? Each machine/device that's connected has the "obtain DNS automatically' in their network settings.

I can't use any other router as they're different make and models and their chipset isn't compatible with my exchange's DSLAM (as I get a much degraded and reduced connection with them).

I'm in the U.K.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48383
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2740R Port Forward not working
« Reply #7 on: May 23, 2012, 01:14:38 PM »

Is there an option to Reserve IP addresses for connected devices?

So if you use this modem in bridged mode you can't use any external router behind the modem due to incompatibility issues with the ISP? Strange. Haven't heard of this before. Does your ISP recommend any sort of external router in use with a stand alone modem or modem that is in bridged mode?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Retro~Burn

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2740R Port Forward not working
« Reply #8 on: May 23, 2012, 01:24:57 PM »

Before I settled on my current router. I tried a Draytek and a Netgear router and I found that my connection speed would be almost half of what it should be. I asked around on another forum and I was told that it's most likely the chipset that they use in their routers. As sometimes they can be incompatible with whatever the exchange uses. I didn't have this problem with my old D-Link DSL-G624T. So I assume it's whatever the other manufacturers use.

From your suggestion, I would use my alternative routers as the 'internet router' and then this D-link one as a 'bridge'?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48383
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2740R Port Forward not working
« Reply #9 on: May 23, 2012, 01:39:18 PM »

I would presume that there was an issue between Draytrek and your ISP service.

Yes, I would use this DLink MODEM in bridged mode. This effectively turns off any router options and functions OFF on the MODEM, making it a stand alone modem. This will pass along to the external ROUTER any and all public addressing and traffic. The external ROUTER will then handle PPPoE or A DSL account info, all traffic, management, port forwarding, Wifi and QoS that it has. Use the external ROUTER to set up reserved IP addresses for ALL connected devices on it then set up QoS and Port Forwarding as needed.

Should look something like this:
ISP DSL Line>DSL-2704B Modem>External Router(Any Router Mfr should work)><connected PCs and Wifi devices to external router.
« Last Edit: May 23, 2012, 02:02:33 PM by FurryNutz »
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Retro~Burn

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2740R Port Forward not working
« Reply #10 on: May 29, 2012, 05:33:00 AM »

The issue has been successfully resolved. I created a case file on the D-Link portal and received a prompt reply with a firmware update which fixed the problem. File is here:

ftp://dlinktemp:dlinktemp@194.117.170.198/ADSL/DSL-2740Ruk/DSL-2740R_revB_UK_101b01.bin

IMPORTANT: After I clicked to upload the file, I would just see a "waiting for 192.168.1.1...." message in the far corner of the browser window. It hadn't updated the page with a progress bar for the update. So I has no idea whether it had been successfully completed or not. I gave it 12 minutes before deciding to reset the router to factory default settings. I had to reset it as I couldn't log back-in.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48383
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2740R Port Forward not working
« Reply #11 on: May 29, 2012, 06:55:21 AM »

So you were able to get Port Forwarding to work using the update?

Just FYI, these temp links may not be enabled for a long period of time. Also this is for a EU or UK units, not for NA or other regions.


Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!