• October 25, 2020, 06:19:45 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: RDP port forward with Hardware Version : B1  (Read 7255 times)

Mixelplic

  • Level 1 Member
  • *
  • Posts: 2
RDP port forward with Hardware Version : B1
« on: March 25, 2012, 11:13:21 AM »

DIR-601, Hardware Version : B1, Firmware Version : 2.00NA

Trying to open up port for RDP (3389) to WinXP machine (tried with DHCP and with static IP on XP workstation)
Tried both Virtual Server (3389 to 3389 and other port numbers to 3389) and a simple Port Forwarding (3389 TCP).  Both methods work correctly for about 15 or 20 minutes, then the router blocks traffic on the opened ports.
If I delete the virtual server/port forward settings and recreate it will again work for about 15 or 20 minutes.
Even tried creating my own schedule (although I would be quite happy with always)

Also can't find a link for the 2.00NA firmware to attemp a reflash, I have only be able to find firmware for the HWverA unit.  (other than the wrt stuff, is there any other firmware for the B1 unit?)

Am I missing somethin' obvious?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: RDP port forward with Hardware Version : B1
« Reply #1 on: March 27, 2012, 06:51:33 AM »

Welcome!
What Hardware version is your router? Look at sticker under router.
What Firmware version is currently loaded? Found on routers web page under status.
What region are you located?
Are you wired or wireless connected to the router?

What ISP Service do you have? Cable or DSL?
What ISP Modem do you have? Stand Alone or built in router?
What ISP Modem make and model do you have?
If this modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems.
To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged.

Some things to try:
Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall if you have this option.
Enable uPnP and Multi-cast Streaming under Advanced/Networking.


Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.
Turn off all devices accept for one wired PC while testing.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Mixelplic

  • Level 1 Member
  • *
  • Posts: 2
Re: RDP port forward with Hardware Version : B1
« Reply #2 on: March 28, 2012, 07:42:49 AM »

I really don't understand what one would have to do with the other, but.....

In Advanced/Firewall Settings check the box: Enable anti-spoof checking...then my virtual server/port forwarding rules seem to stick.  If I uncheck the box they again disapear after about 15min.



...i also noticed someone removed my facepalm post, pls remember:
"A joke is a very serious thing."
Winston Churchill
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: RDP port forward with Hardware Version : B1
« Reply #3 on: March 28, 2012, 07:49:42 AM »

Odd that this option effects VS and PF options. I guess if it works for you.

Your post was probably removed for violating forum guidelines.  ::)

Enjoy.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!