• January 22, 2020, 07:03:05 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DIR130 Firmware 1.23 is broken .. do not use!  (Read 4141 times)

shalodge

  • Level 1 Member
  • *
  • Posts: 6
DIR130 Firmware 1.23 is broken .. do not use!
« on: May 08, 2011, 04:12:58 AM »

I am a network engineer working on a Radio Network project for the NZ Coastguard.  I have deployed IPSEC VPNS using Dlink gear for VOIP radio links.  The hub is a DFL210 and the endpoints are DIR130s.  I have deployed over 12 DIR130s with no problems until I obtained two of the latest DIR130s to extend the network and ran into major problems.  Previous units ran 1.22 Firmware but the latest units came with 1.23.

I deployed the 2 new 130s on remote sites and tested .. no problems.. The next morning the devices were down and had to be power cycled to get them up again.  They then worked perfectly until the next morning they were again down.

Testing revealed that if the single IPSEC VPN tunnel was disabled they stayed up so the problem was with the VPN.

The devices were then rolled back to firmware 1.12 (supplied by Dlink AU via support desk).  This appeared to work until the unit tried to use the existing config at which point the GUI authentication failed.

The situation was not resolved until I travelled on site to do a hardware restore to defaults. Even with the firmware rolled back to 1.12 as soon as I loaded the original config the unit GUI authentication failed.  I had to reset to defaults and reconfigure from scratch.

The units are now working well on 1.12 as are the others on 1.22.  This matter has been reported to Dlink AU but no response.  CG NZ are likely to pursue legal action to recover approx $5k that was incurred in recovering from the faulty firmware.

I note that 1.23 is still the firmware listed for download on the DIR130 support site.  Do not upgrade! If you do it will be fine until you configure an IPSEC VPN at which time your GIU authentication will fail and you will be shut out until you do a hardware reset to defaults..

Russell ORR
Orrcom ltd
NZ

Logged