• November 13, 2019, 03:30:59 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 2 [3]

Author Topic: Sudden Drop in Transfer Speed - Was > 100Mb/sec.... Now about 8Mb/sec  (Read 26988 times)

mihies

  • Level 2 Member
  • **
  • Posts: 29

You're griping about <20MB/sec throughput, I make a statement about pushing 50MB/sec through the NIC and you somehow infer that I'm saying the NIC is the bottleneck?

Doesn't that sound backward to you?

Ah, ok, I've thought you've hacked it to perform better. My bad. So you are saying that you pushed it to 50Mb/s with what? Dummy data?
Logged

Steve Pitts

  • Level 2 Member
  • **
  • Posts: 68
  • A twelfth man at silly mid on

procesor not being able to transfer speeds of above 24MB/s. Are you really serious?
Yes. It isn't just about pushing around data, it is everything from managing the IP stack to checking directory structures, permissions etc. I have been doing a fair bit of testing both of the DNS-323 and my network and I've not managed to better 24MB/s when copying various large workloads between the two oldest machines on my network - two five year old desktops, one a Dell GX620 with a 2.8GHz Pentium D and the other a Mesh (UK box shifter) Athlon 3500+, both with more RAM than the NAS - which are of a similar age to the original release of the DNS-323.

I know that my network infrastructure is capable of better than that because I can get 40MB/s or better when shifting data between my new CryoPC i7 2600K @ 4.8GHz and the two and a half year old Toshiba laptop with a 2.53GHz Core 2 Duo (and could no doubt do a lot better than that if I had two i7 beasties and involved the SSD rather than limiting myself to the HD). None of my machines are optimised for a file server role, and could probably be tweaked to perform better than they do, but there are all more powerful than the processor in the NAS and would seem to provide comparable data points.
Logged
Cheers, Steve

Running a DNS-323 Rev. C1 with FW 1.10b5, fun_plug 0.5 and 1 Western Digital WD20EARS-00MVWB0, 4K aligned by 1.10FW, in Standard mode as a single volume

fordem

  • Level 10 Member
  • *****
  • Posts: 2168

Ah, ok, I've thought you've hacked it to perform better. My bad. So you are saying that you pushed it to 50Mb/s with what? Dummy data?

Rev A hardware, only "mod" is a custom fun_plug that loads a telnet daemon so that I have shell access.
Logged
RAID1 is for disk redundancy - NOT data backup - don't confuse the two.

mihies

  • Level 2 Member
  • **
  • Posts: 29

Yes. It isn't just about pushing around data, it is everything from managing the IP stack to checking directory structures, permissions etc.

Sure, there are some checks to be performed. But once those are done it boils down to transfer from network to disk (imagine big files) or in other direction. If I were to build a (cheap) NAS I would take care of transfer speeds and robust firmware first and then I'd add a ton of other more or less usable features. IOW even when it comes to a cheap NAS like this is, transfer speed should depend on disks only, not on anything else. Perhaps the speed is limited by lousy firmware and not hardware.
Logged

EBS

  • Level 1 Member
  • *
  • Posts: 6

Hello all,

Since I started all this, I thought I should post the resolution.
It was the switch.
I replaced the switch and I get 55Mbps both to and from the 323(s). I can plug the old switch back in and duplicate the problem. The only symptom is that transfers from either 323 through the switch drop down to 8Mbps or less (often 1Mb). 

EBS
Logged

Bomster

  • Level 1 Member
  • *
  • Posts: 5

Hello all,

Since I started all this, I thought I should post the resolution.
It was the switch.
I replaced the switch and I get 55Mbps both to and from the 323(s). I can plug the old switch back in and duplicate the problem. The only symptom is that transfers from either 323 through the switch drop down to 8Mbps or less (often 1Mb). 

EBS

Hi there,

Just been following this thread I also feel I'm suffering from pretty low transfer speeds. I'm new to using a NAS, so when you say that you 'changed the switch', what does that mean?

Thanks alot,
Tom
Logged

Steve Pitts

  • Level 2 Member
  • **
  • Posts: 68
  • A twelfth man at silly mid on

I also feel I'm suffering from pretty low transfer speeds
Any concrete data?? How slow is 'pretty low'??

Quote from: Bomster
when you say that you 'changed the switch', what does that mean?
Nothing to do with the NAS as such, the switch in this context is a network switch (a device that routes data from one directly attached device to another). Many home networks don't use switches but instead may have a network hub (which serves the same purpose as a switch, but broadcasts any data to all directly attached devices, and becomes considerably less effective as the number of directly attached devices increases) or a router of some description (which can route data to different networks and will normally be connected to both the Internet and the local network in a SOHO type environment). These days many home setups just have a broadband router which, in addition to connecting to the outside world and providing a handful of wired network ports, will also have a wireless capability.

Bottom line is that the original problem was nothing to do with the DNS323 but instead was probably a fault in the network switch (a Netgear GS605, as per the OP).

Moral of the tale is probably that selling NAS devices as something that you can simply plug in and get working well without any technical knowledge of networking is probably a little optimistic and no doubt results in a significant percentage of the support requests for these kinds of devices.
Logged
Cheers, Steve

Running a DNS-323 Rev. C1 with FW 1.10b5, fun_plug 0.5 and 1 Western Digital WD20EARS-00MVWB0, 4K aligned by 1.10FW, in Standard mode as a single volume
Pages: 1 2 [3]