• November 30, 2015, 09:40:29 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: xbox 360 cannot connect to network  (Read 4461 times)


  • Guest
xbox 360 cannot connect to network
« on: October 25, 2008, 11:38:43 AM »

My 360 does not connect to the network or if I get lucky, it connects for about 3 seconds then disconnects.

First - all my other devices - 2 desktops and a wireless laptop - connect just fine and have no issues.

Even better is that my ****py old Linksys WRT54G works just fine.


I had a 360 that my son took to college (imp). It was running on the DGL-4500 just fine - hard wired. I got a new console and installed it the day after XboxLive did their upgrade (9/29). All connection tests on the 360 fail at "Network Adapter" about 95% of the time.  Was it does connect, it disconnects in about 3 secs.

At first I thought it was a faulty Xbox as there would be no reason for the router to fail. I tried the other ports on the router with the same results and no settings had been changed since the older console was taken away.

I return the console a got another one - has the same problems.

I can connect direct through the cable modem and have no XboxLive connection issues.

I upgraded to firmware 1.12.  Same problems. I upgraded to firmware 1.13. Same problems.  I have since reverted back to 1.12.

I have tried port forwarding and a static IP to no avail.

As you can tell it is driving me nuts.  Any help appreciated
« Last Edit: October 25, 2008, 12:05:55 PM by stoutr »


  • Level 2 Member
  • **
  • Posts: 51
    • D-Link Technical Support
Re: xbox 360 cannot connect to network
« Reply #1 on: October 25, 2008, 04:35:27 PM »

Hello soutr,

Very interesting problem and I feel a little overwhelmed and dumfounded. I remember that update myself and when I looked more into it it appears they actually didn't update anything. Just on their server end. The real XBOX live update will be released later on. I know that's not helping your problem much but it may have been just a coincidence.

DGL-4500 Gaming and Gamefuel for XBL
Router Troubleshooting Suggestions and Tips

Try a different network cable, perhaps the same cord connected to one of the working desktops. I'll try to ask some colleagues if they have ideas and possible solutions.

Best of Luck,

« Last Edit: October 25, 2013, 11:21:56 AM by FurryNutz »


  • Guest
Re: xbox 360 cannot connect to network
« Reply #2 on: October 25, 2008, 08:09:55 PM »


Unfortunately the Xbox is about 50 feet away from the router.  Cable runs under the carpet into the other room.  I am not sure that I have another long cable but will give that a try if I can.  A little pessimistic that it is the cable since the current one works when directly connected to the modem and is currently working - being connected to the Linksys.




  • Guest
Re: xbox 360 cannot connect to network
« Reply #3 on: October 25, 2008, 09:47:02 PM »

I know this may sound really silly, but try 100% removing all port-forwarding rules you've created. I had a problem with Steam based games on my computer, and the problem was created when I made rules to open ports.

I was told that UPnP wasn't properly functioning with fw1.12 and fw1.13. This has been an on-going problem; all I know is when I removed all my rules for port-forwarding, the problem was remedied.

Working in computer retail for a major company, I've shared my concerns with my D-Link representative. Not sure when and/or if any of this will be 100% addressed and repaired. But it's sure a fun story to tell customers.  :(


  • Level 1 Member
  • *
  • Posts: 15
Re: xbox 360 cannot connect to network
« Reply #4 on: November 01, 2008, 11:10:48 AM »

I am having a very similar issue. After upgrading my firmware to 1.13 I can no longer connect to Xbox Live with a solid connection speed. If I plug directly into the DSL modem, I can play on Xbox Live with 4 green bars of connection, no problem. The best I can get when playing through the router is 2 yellow bars. I have tried everything I can think of to see if it will help and nothing has worked. (on a side note, moving the Xbox 360 into the DMZ actually made the problem worse. It would connect to Xbox Live, but not to a game host.  ???)
I have since gone to version 1.12, but it is having the same issue. I did not have this issue with the older firmware version I had (I think it was 1.02 but I can't be 100% positive). Lucky me, firmware 1.12 wont let you go back to an older version.
 I noticed in the previous post it stated that version 1.12 and 1.13 of the firmware are having issues with UPnP. How soon will that be fixed?
I would think a firmware issue with UPnP would be a high priority to get resolved.