• December 05, 2019, 07:00:23 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Cannot get 655 to connect wirelessly to Toshiba A60 Laptop. Warning, long post!  (Read 5603 times)

swissgator

  • Guest

OK here goes. I cannot get the wireless to connect to my A60. The ethernet connection works great. First here is what happens and then a list of what I have done.

I can pick up around 10 wireless networks around my apt. which are all secure. With every network EXCEPT mine, I click to connect and a popup prompts me for password. My network does not do that (even after removing it from preferred list of networks). What mine does is just connect and then says it is checking validity. This goes on forever and it never connects or it says that it can't confirm my certificate. Now, I know that it should ask me for a wpa key and then I should be able to connect, but this never happens. OK, now for a list of things I have done:

firmware check: 1.11EU 1007/11/5
authentication for 802.11 IEEE: unchecked
manually configured connection with wpa-psk, tkip, and passphrase. This is exactly same as router config. I also removed the network from the preferred list before the manual config.
wpa only, with personal not enterprise
disable wifi protected setup
system file check for windows xp home edition SP3
powered up and down router several times.
checked for latest driver for the laptop's wireless adapter

There might be a few more things I tried but just can't keep track. FYI I have the following that do connect wirelessly without a problem:

24"imac with OS 10.5.5 and bootcamp into XP Pro SP3
12" Powerbook G4
Homebuilt PC XP Pro SP3

So 4 machines (or systems) out of 5 connect. The Toshiba is the only thing that won't cooperate!! Does anyone know what the problem is here? My last thought is to do the old support standby and reformat/reinstall XP.  :-[

Thanks for advice and if anyone from Dlink or Toshiba is out there....help!!

Dan
Logged

Fatman

  • Level 9 Member
  • ****
  • Posts: 1675

I can't quite tell if you have done this from the above, it looks like you may have, but it is my best advice so I will say it anyway.

Try manually creating a preferred wireless profile, make doubly sure that you give it your WPA key then and that 802.1x is unchecked.
Logged
non progredi est regredi

swissgator

  • Guest

Hey Fatman,

Yes, I already tried that both by adding the connection completely manually and I also tried to modify the properties once the network was listed in the preferred list. In both cases I made sure I removed the previous network attempt in the preferred listing.

One last thing. I just tried booting in safe mode with networking capability and this time it did ask for my passkey  :o However, when I entered it in, it said it had to be at least 10 hex-dec characters, etc. Well, my key meets that requirement, but doesn't allow me to move further. Ideas? Am I on to something???

Thanks
Logged

swissgator

  • Guest

Success!!! I updated the wireless driver from another source after much searching and am happy to report all is working perfectly now!  :) Thanks for replies!
Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335

Nice find.
Logged

wiak

  • Level 2 Member
  • **
  • Posts: 60

drivers do all the diffrent, d-link should learn to put the latest chipset manufacturers drivers on their site or link to them, most of d-links drivers like for my DWA-140 was outdated last year :P
compared to ralink drivers that was updateds ~2 months ago

anyway good to see that your laptop works swissgator
and keep up teh good work lycan
Logged