• October 23, 2019, 03:05:32 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: 1.12EU Beta Firmware - anybody tried it?  (Read 14091 times)

redhomey

  • Guest
1.12EU Beta Firmware - anybody tried it?
« on: September 16, 2008, 02:15:17 AM »

On the EU product page (use the link on the header of the EU firmware login page) there is reference to  firmware version 1.12EU Beta. This does not get automatically added by the firmware check - presumably because it is in Beta.

1.12EU_B01      Fixes the compatibility issue with DSL-320T and DSL-320B.      05-09-2008     
(referring to two ADSL modems)

There is a broken link on this page to it this firmware.
You can get to it though by pointing your browser at:
ftp://ftp.dlink.co.uk/dir_products/dir-855/

Anybody tried it? Any other improvements?

Yes it is wishful thinking... just the 2.4Ghz range on this router is so poor considering its price.  :'(
Logged

ssnickerss

  • Level 1 Member
  • *
  • Posts: 10
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #1 on: October 10, 2008, 08:43:36 AM »

Is this the same as the US 1.12 ?
Why is it a beta version for EU.

A+
Logged

madhatter

  • Guest
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #2 on: October 24, 2009, 07:44:31 AM »

I'm running 1.13EU never had any problems at all so far.Logs say up for >48 days and no problems.
Logged

nicceg

  • Level 2 Member
  • **
  • Posts: 44
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #3 on: November 21, 2009, 10:09:39 AM »

Any news about a updated version?
I am soon about to give up on DIR-855. System stable
but a few features doesn't work. Will never buy D-Link again.
Logged

jeps

  • Level 1 Member
  • *
  • Posts: 2
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #4 on: November 22, 2009, 04:08:00 AM »

I'm running 1.13EU never had any problems at all so far.Logs say up for >48 days and no problems.
I know of 1.12 B19 (thats is the one I am using right know), but I have never seen 1.13EU. Can you provide a link for that firmware
Logged

lizzi555

  • Level 5 Member
  • *****
  • Posts: 605
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #5 on: November 22, 2009, 04:15:11 AM »

It's on D-Link FTP Germany:

ftp://ftp.dlink.de/dir/dir-855/driver_software/DIR-855_fw_reva2_113EUb02_ALL_multi_20090204.zip
Logged

jeps

  • Level 1 Member
  • *
  • Posts: 2
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #6 on: November 22, 2009, 10:36:55 PM »

This is strange.
The 1.12 B19 firmware, I am using, is officially dated 27. August 2009
The 1.13 B02 firmware in you link is officially dated  4. February 2009

Does anybody have an idea, why the dates (or version numbers) are out of sync
Logged

lizzi555

  • Level 5 Member
  • *****
  • Posts: 605
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #7 on: November 23, 2009, 03:56:27 AM »

These things may happen because D-Link developes different lines of firmware.
They are not always consequent regarding the numbering.

1.13 is from EU series and 1.12b19 is from WW series of firmware.

Latest ww firmware I found is here:
ftp://ftp.dlink.ru/pub/Router/DIR-855/Firmware/DIR8522A2_FW120WWB06Beta.bin
Logged

nicceg

  • Level 2 Member
  • **
  • Posts: 44
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #8 on: November 25, 2009, 01:48:53 PM »

North America has version .21b07
This version also has a number of features missing from the European version.
Logged

SanderT

  • Level 1 Member
  • *
  • Posts: 15
Re: 1.12EU Beta Firmware - anybody tried it?
« Reply #9 on: November 30, 2009, 05:38:45 PM »

I'm using the 1.12EUb19 firmware without problems for months now. I tried the 1.13 EU firmware a few months ago, it has the same WAN slowdown and lockups which were present in the 1.20/1.21 firmwares (until the recent 1.21b07 which fixed the problem in the 1.21 NA version).

I think the 1.13EU firmware and the former 1.20/1.21NA (before b07) were based on the same codebase. maybe a dev can give insight. But the 1.13EU firmware has the same problems as were fixed in the 1.21b07 for their NA releases. Hope they can also update the 1.13EU release.
« Last Edit: November 30, 2009, 06:01:37 PM by SanderT »
Logged