• May 25, 2020, 09:29:14 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: WOL  (Read 7029 times)


  • Level 1 Member
  • *
  • Posts: 3
« on: December 08, 2010, 08:35:30 AM »

I frequently remotely connect to my desktop computer at home, and I would like to keep it in standby in between uses. My desktop computer is configured properly in the BIOS for WOL, and the network adapter is also capable of WOL. How do I configure the router for WOL? I tried going to the Advanced tab and then Virtual Server. I selected Wake-On-LAN from the Application Name list. I then selected my computer and both under protocol, leaving the default settings. This did not help. Thanks in advance!


  • Poweruser
  • ††▲
  • *****
  • Posts: 48790
  • D-Link Global Forum Moderator
    • Router Troubleshooting
« Reply #1 on: December 08, 2010, 08:59:24 AM »

I haven't tried this as I dont' have a use however looking at other posts, seem like alot of people have notice some issues regarding this.
Are there any port forward entries that need to be set up by chance?

Here are some post in hopes that it will help you to get it going. Please let us know if you do.



Anyone else using WOL?

"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!


  • Level 3 Member
  • ***
  • Posts: 126
« Reply #2 on: December 10, 2010, 07:44:01 AM »

I'm using it.

I got it to successfully work for my WHS.  So I can wake it up then remote in and put it back to sleep.  Even works from my Ipod Touch. :)

First off, you had better have a dyndns setup in the router, otherwise whenever your ip changes, this won't work.

In virtual servers I had to forward this way:  Wake-On-LAN  UDP 9 → 9  

my servers ip reservation is setup as, but for some reason WOL wouldn't work for that, but works when its set to .255  

I found that on a forum post after struggling with it for days.

Make sure you allow port 9 or whatever port you use through windows firewall on any subnet or it won't work either.

I use this site to wake my machine remotely: http://www.depicus.com/wake-on-lan/woli.aspx

Let me know if you want to know which iPod apps I use.

Tech info:
DGL-4500 FW: 1.15
SPI Enabled
Address Restricted for both UDP and TCP endpoint filtering
Anti-spoof checking -unchecked (I haven't tried it with it checked)

DAP-1522  FW: 1.21
Static IP set to the DHCP Reservation setup on the DGL-4500

« Last Edit: December 10, 2010, 08:30:25 AM by motherfo »


  • Level 1 Member
  • *
  • Posts: 7
« Reply #3 on: January 27, 2011, 01:45:39 PM »

Has anyone been able to get WOL to work with DIR-655 v2 FW: 2.00?



  • Poweruser
  • ††▲
  • *****
  • Posts: 48790
  • D-Link Global Forum Moderator
    • Router Troubleshooting
« Reply #4 on: February 03, 2011, 09:28:43 AM »

This is what MotherFo sent me. Let us know if this works.

1. Setup a DynDNS in your router.

Tools | Dynamic DNS


I personally use http://www.dyndns.com/

Setup an account and fill out the information in your router.

Once you enter it, it should say connected by status.

Reasoning: Dynamic DNS is a great tool for when you have an internet service that doesn't issue static (non-changing) IP addresses.  Dynamic DNS will always update your IP/hostname whenever it changes.  This is great if you host servers or need to remote access your computers.  The same rules apply to WOL.  You can't send a packet to some random IP address and expect yours to wake up.

2. Setup DHCP Reservations in your router.

Basic | Network

Adding a DHCP reservation is pretty self-explanatory.  I recommend doing it for all your common machines.  Setup the one you want to use WOL with.  Make note of the MAC Address as you will need this to use utilities to wake up your machine.

Reasoning: DHCP Reservations secure a LAN IP for that particular computer.  (192.168.0.xxx)  The xxx part will change if these are not setup and you are using DHCP.  It essentially makes it have a static IP.  By securing a particular LAN IP, if your router reboots, your port forwards don't get screwed up.

3. Configure network card.
The next step is to configure your network card/Ethernet card.  I'm not 100% positive if you can do this successfully on wireless cards, but my server is plugged into my DAP-1522 which is wireless.

This also depends on your operation system version.

Win 7/Vista: Start | Control Panel | Network and Sharing Center | Click on Local Area Connection | Click on properties | Click Configure
I recommend setting up a static IP on the particular computer.  Then setup the power/adapter settings for WOL.

I donít believe it is necessary to specify your DNS addresses.  I have setup the Static IP and DNS because if I leave it on obtain automatically, it takes it longer for my network to load my server folders.

4. Check Firewall Settings in Router

These are the settings I use, I cannot confirm if anti-spoofing has to be checked or not.

5. Forward Port in Virtual Server.

Advanced | Virtual Server

Forward port 9 to
This step is crucial.  It would not work when I tried to forward it to the IP of the machine I needed to wake up.  .255 is what made it work for me.

6. Disable Windows Firewall or Add Exception

Disable Windows Firewall or Add Exception to Port 9 and change subnet to All/Internet.
You should probably do the same if you have another firewall program installed, but I don't use any others.

7. Websites, programs, and iPod apps.

Here are some websites you can use to send WOL packets:
* indicates the ones I use.

http://www.depicus.com/wake-on-lan/woli.aspx    *


Here are some programs that can send WOL packets:

http://www.depicus.com/wake-on-lan/wake-on-lan-gui.aspx   *


Here are the names of iPod Touch/Phone apps:

NetAwake (Free) *

"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!