• November 28, 2014, 08:45:27 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in which we have created boards at this time.

Author Topic: Configuring firewall settings for router  (Read 4654 times)

Rob56

  • Level 1 Member
  • *
  • Posts: 6
Configuring firewall settings for router
« on: October 21, 2010, 12:43:23 PM »

I have a DIR-615 router serving as a access point for my two desktops running Windows XP and Nintendo Wii Console.  Everything works great, too good in fact.  Now I am trying to set up my new Wireless Lexmark S308 Printer to serve the two desktops and it can't find my router; unless I disable my firewall settings on the router (then it finds it no problem) I don't want to run my network without the routers firewall, but I need the printer to work with my network......HELP!
Logged

Trikein

  • Guest
Re: Configuring firewall settings for router
« Reply #1 on: October 21, 2010, 09:06:31 PM »

This is more a question for your printer manufacturer. Sounds like a port issue. Have you spoken with them first?
Logged

Rob56

  • Level 1 Member
  • *
  • Posts: 6
Re: Configuring firewall settings for router
« Reply #2 on: October 21, 2010, 10:17:28 PM »

This is more a question for your printer manufacturer. Sounds like a port issue. Have you spoken with them first?
Yes, and they told me to contact D-Link regarding the firewall setup.  They are aware it works with the firewall disabled, thus they pass the buck so to speak.  I agree that it could be a port issue on the LAN side as the printer is probably sending a echo request and waiting for a echo reply.  Not sure which port to open or how to do so.
Logged

smlunatick

  • Level 5 Member
  • *****
  • Posts: 625
Re: Configuring firewall settings for router
« Reply #3 on: October 22, 2010, 07:07:13 AM »

Wireless printers do not pass the "packets" through the firewall as the traffic is on the LAN part of the router.   If the wireless printer is not able to  see the router, it could be not using the same wireless network security.
« Last Edit: November 02, 2010, 11:35:55 AM by smlunatick »
Logged

Trikein

  • Guest
Re: Configuring firewall settings for router
« Reply #4 on: October 22, 2010, 05:20:06 PM »

What process are you using to add the printer? WPS with Pin? With button? Manual entry? What type of security? WEP or WPA?

I was confused at first, I thought you were saying the PC cant see the printer on the network with the router firewall, where the firewall MIGHT play a role. But if printer cant even SEE the router, like doesnt list the SSID, I would suspect a issue with the radio (make sure its on G only or G and N) or the Channel (Choose Auto scan first, then manually set to 1 or 11 if you have to).
Logged

Rob56

  • Level 1 Member
  • *
  • Posts: 6
Re: Configuring firewall settings for router
« Reply #5 on: October 22, 2010, 05:56:43 PM »

Wireless printers do not pass the "packets" through the firewall as the traffic is on the LAN part of the router.   If the wireless printer is not see the router, it could be not using the same wireless network security.
Sorry, I stand corrected.  The printer does see the SSID and I am running WPA2-PSK, which the printer is supposed to be comfortable with.
Logged

Trikein

  • Guest
Re: Configuring firewall settings for router
« Reply #6 on: October 22, 2010, 06:11:47 PM »

Then it probably is. The thing is, it may not be using it properly. Have you tried adding the network settings manually? Also, most CD that come with printers suggest that if you cant get it to work wireless, tempororyly connect it wired, and let the PC(via the CD) configure the printer. Or, try turning the network to WPA or WPA with TKIP. The PSK doesn't matter, since all your security will be PSK(except if you use WPS)
Logged

Rob56

  • Level 1 Member
  • *
  • Posts: 6
Re: Configuring firewall settings for router
« Reply #7 on: October 22, 2010, 06:13:26 PM »

What process are you using to add the printer? WPS with Pin? With button? Manual entry? What type of security? WEP or WPA?

I was confused at first, I thought you were saying the PC cant see the printer on the network with the router firewall, where the firewall MIGHT play a role. But if printer cant even SEE the router, like doesnt list the SSID, I would suspect a issue with the radio (make sure its on G only or G and N) or the Channel (Choose Auto scan first, then manually set to 1 or 11 if you have to).

I have tried adding the printer with WPS with Pin and also the manual route, no luck. Running WPA2-PSK.  My mistake, the PC can see the printer (via the current USB hookup) and the printer finds my SSID.  No matter which way I try, the printer comes back with "Can't associate with wireless network". 
Currently using mixed mode G and N (the Wii Console wants the G) and Auto scan.
Other items of interest, my firewall settings show SPI is enabled and the NAT Filter is showing UDP with address restricted, TCP with Port and address restricted.  MAC filtering is off.
Anyone have any suggestions??
Logged

Trikein

  • Guest
Re: Configuring firewall settings for router
« Reply #8 on: October 22, 2010, 06:58:12 PM »

Well it has nothing to do with the firewall. The firewall is between the WAN(Internet) and LAN(your network). It would be like walkie talkie not working in your house and having it be how you lock your front door? Not to say it isn't a setting on the router, but its likly the wireless settings, not the firewall. So your saying it connects with WPA2-PSK when you disable SPI? What are you meaning when you say firewall? Do you maybe mean wireless security?
Logged

Rob56

  • Level 1 Member
  • *
  • Posts: 6
Re: Configuring firewall settings for router
« Reply #9 on: October 22, 2010, 10:09:56 PM »

Well it has nothing to do with the firewall. The firewall is between the WAN(Internet) and LAN(your network). It would be like walkie talkie not working in your house and having it be how you lock your front door? Not to say it isn't a setting on the router, but its likly the wireless settings, not the firewall. So your saying it connects with WPA2-PSK when you disable SPI? What are you meaning when you say firewall? Do you maybe mean wireless security?
I have to agree, it is looking more like the wireless settings and not the firewall as I assumed.
Using WPA2-PSK with SPI disabled, still does not connect.  But if I change the Wireless Security mode from WPA to None it works!  I assumed that doing this was part of the firewall settings.  Still have a lot to learn I can see.  Hope this narrows down the problem
Logged

Trikein

  • Guest
Re: Configuring firewall settings for router
« Reply #10 on: October 22, 2010, 11:57:38 PM »

Very much so. We have shown its a wireless issue. Still think its something your printer manafacture should pick up, but I know better then most how useless bad support can be.

Try Setting it like this

WI-FI Protected Set up= Uncheck. This will reset the security, thats ok.
Enable Wireless: Checked
Wireless Network Name: <Insert your network name>
802.11 Mode: Mixed 802.11n and 802.11g
Enable Auto Channel Scan: Yes
Chanel Width Auto 20/40
Visibility Status: Visible.

Security Mode: WPA Personal
WPA Mode: WPA Only
Cipher Type: AES
Group Key Update Interval 3600

Pre-Shared Key: (retype this to confirm)

Click on Save settings, reboot if needed.

If that doesn't work change Cipher type from AES to TKIP, but I want to try it first with AES. Then just manually enter those settings into the router or with the CD, but don't use WPS. The act of using WPS changes some of those settings, thats why we turned it off. It also uses WPA2 by default. Let me know how it goes.
Logged

Skello

  • Level 3 Member
  • ***
  • Posts: 140
Re: Configuring firewall settings for router
« Reply #11 on: October 23, 2010, 01:32:46 AM »

Unfortunately, WPA is vulnerable. WPA is basically a strengthened version of WEP.

It's not as easy to crack a WPA key as it is a WEP one (which takes seconds or minutes), and requires rainbow tables and such, but it is doable.

There's even commercial cloud-based services to do it faster, like wpacracker.com.

Ultimately, it's for you to decide the likelihood of attacks against your network and if WPA is enough to protect it.
Logged

Rob56

  • Level 1 Member
  • *
  • Posts: 6
Re: Configuring firewall settings for router
« Reply #12 on: October 23, 2010, 01:39:47 PM »

Very much so. We have shown its a wireless issue. Still think its something your printer manafacture should pick up, but I know better then most how useless bad support can be.

Try Setting it like this

WI-FI Protected Set up= Uncheck. This will reset the security, thats ok.
Enable Wireless: Checked
Wireless Network Name: <Insert your network name>
802.11 Mode: Mixed 802.11n and 802.11g
Enable Auto Channel Scan: Yes
Chanel Width Auto 20/40
Visibility Status: Visible.

Security Mode: WPA Personal
WPA Mode: WPA Only
Cipher Type: AES
Group Key Update Interval 3600

Pre-Shared Key: (retype this to confirm)

Click on Save settings, reboot if needed.

If that doesn't work change Cipher type from AES to TKIP, but I want to try it first with AES. Then just manually enter those settings into the router or with the CD, but don't use WPS. The act of using WPS changes some of those settings, thats why we turned it off. It also uses WPA2 by default. Let me know how it goes.

What a Lexmark piece of junk!  I used the above settings (with AES) no luck, then changed it to TKIP, again no luck.  I set it to NONE, guess what it works!  This printer (802.11g wireless print server) is supposed to be N router compatible. Even my Wii Console which runs in g mode, works great under the mixed mode g/n.  I have gone over the printers requirements and I quote "works under WEP, WPA and it HIGHLY RECOMMENDS WPA2 (using AES) (use TKIP with WPA) use 20 Mhz instead of Auto 20/40 Mhz and the router must run at 2.4 Ghz (not 5 Ghz compatible) and of course the DHCP must be enabled"
Thanks for sticking with me on this, but it looks to me, like the print server might be defective??
Of course I can hook it to one of the desktops via the USB cable, but I bought it for it's wireless features.
Is there anything left to try or have I reached a dead end??
Logged

Trikein

  • Guest
Re: Configuring firewall settings for router
« Reply #13 on: October 23, 2010, 08:56:19 PM »

Well there you go. So its not working with WPA2 with AES, so try WPA with TKIP. The difference in WPA-AES and WPA2-AES are pretty small, and more related to standards(how it is used by default) then any big change on how it works. Could be a defective AES chip, yes. You don't need a print server most likly. You can just wire it wired to the router and then security doesn't play a role. You will have to run the CD but it will eliminate a big part of it.
Logged