• October 23, 2017, 10:03:22 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: D-Link USB VoIP setup Wizard ended Prematurely - Please help me...going crazy  (Read 11246 times)

lolly

  • Level 1 Member
  • *
  • Posts: 2

Hello to the dear person reading this. I hope you can help me.
I've had this (D-Link DPH-50U VoIP adapter) for 4 months now and haven't been able to use it.

...I'm running Windows Vista Home Premium (service pack 2)
Dell Inspiron 531 - 32 bit operating system.

I canNOT get this D-Link DPH-50U VoIP adapter installed.
It says the driver is working correctly when i go to device manager....
but this happens everytime....

D-Link USB VoIP Adapter Setup Wizard ended prematurely
-D Link USB Adapter setup ended prematurely because of an error. your system has not been modified. To install this program at a later time, please run the installation again.

If anyone can give me some pointers, i'd greatly appreciate it.

thank you.


Logged

tricky

  • Level 1 Member
  • *
  • Posts: 24

I have the dlink running fine in windows 7 so possibly the same may apply to Vista.

Make sure you have the latest driver 1.01  I think it is.

Extract all the files to a folder

Run setup.

This is the part that is different for windows 7 from XP

Open devices & printers  from the start menu.

Locate the dlink USB voip adapter and right click select properties, select hardware/properties/driver  and update the driver, browsing to the folder you extracted the driver to.

Hopefully Vista works the same way
Logged

lolly

  • Level 1 Member
  • *
  • Posts: 2

Thanks Tricky...Do you have a Windows 7 - 32 bit system or 64 bit? I just got a new laptop with Windows 7 (64bit) and i was hoping i could install the d-link on that, but that doesn't work either.

I had done all that you said to do...with the latest driver. But still no luck.

> sorry it took me a long time to respond, but my forum email was going to my spam box.

I hope that i can get this resolved. any help or suggestions are so much appreciated.

still going crazy.  ???
Logged

tricky

  • Level 1 Member
  • *
  • Posts: 24

I am using windows 7 32bit
I do believe there is a problem using 64 bit though.

Skype works perfectly on my system, my friends using it on his win 7 32 bit too
Logged