• October 28, 2020, 08:08:13 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: One-way communication on port  (Read 9810 times)

jameshaworth

  • Level 1 Member
  • *
  • Posts: 5
One-way communication on port
« on: September 03, 2010, 03:12:57 AM »

Hello,

We have several Linux servers connected to our D-Link DES-1252 switches.

Occasionally, we will find we cannot SSH or Ping to a server. The activity light on the port blinks as normal but we cannot reach it.

The solution is to change ports, which instantly restores connectivity.

I reset the statistics on the D-Link and this is what the statistics on the port look like when the problem occurs:

TX
OutOctets 0
OutUcastPkts 0
OutNUcastPkts 0
OutErrors 0
LateCollisions 0
ExcessiveCollisions 0
InternalMacTransmitErrors 0
RX
InOctets 466170
InUcastPkts 0
InNUcastPkts 7201
InDiscards 0
InErrors 0
FCSErrors 0
FrameTooLongs 0
InternalMacReceiveErrors 0

As you can see, nothing is being transmitted to the server.

Can anyone suggest why this may be happening?
Logged

Fatman

  • Poweruser
  • Level 9 Member
  • ****
  • Posts: 1675
Re: One-way communication on port
« Reply #1 on: September 03, 2010, 03:15:47 PM »

duplex setting shown on the switch and server?
Logged
non progredi est regredi

jameshaworth

  • Level 1 Member
  • *
  • Posts: 5
Re: One-way communication on port
« Reply #2 on: September 06, 2010, 01:09:23 AM »

Duplex setting is Auto on the switch and forced at 100mbps on the Linux server.
Logged

Fatman

  • Poweruser
  • Level 9 Member
  • ****
  • Posts: 1675
Re: One-way communication on port
« Reply #3 on: September 07, 2010, 09:16:03 AM »

If you lock down a full duplex setting on one side you must lock down a full duplex setting on the other side or you will get a duplex mismatch.  If you can only lock down on one side, you must use half duplex.  Try setting both sides to autonegotiate.
Logged
non progredi est regredi

jameshaworth

  • Level 1 Member
  • *
  • Posts: 5
Re: One-way communication on port
« Reply #4 on: September 07, 2010, 09:18:55 AM »

Ok, I'll give that a go.

Thanks.
Logged