• September 21, 2020, 03:55:43 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: uPNP DLNA 2104 error  (Read 3844 times)

angusmac

  • Level 1 Member
  • *
  • Posts: 9
uPNP DLNA 2104 error
« on: April 04, 2010, 05:15:45 AM »

Hi All,

Hoping you can help.

Brand new DNS-343.

2 x 1Tb drives set up on JBOD - approx 50% full.  1 x 1Tb drive as a separate volume - about 5% full.   Running firmware 1.03. No dhcp.  Static IP addresses set.  

Streaming content through a PS3 and having a few issues. All files set in subdirectories not in the root folder. Everything connected by ethernet cable (as opposed to wireless).

First - and I gather this is a known issue - the uPNP doesn't seem to transmit the existence of mp4/avi files.  Very highly annoying.

Second - occasionally during streaming I get a DLNA error 2104 error showing up which causes the system to sieze.  The only way to get rid of it seems to be to reboot the system.

From research should I:

a) Reset the firmware to 1.2
b) Accept the limitations of the DLink uPNP and get Mediatomb or similar installed
c) Other?

Your thoughts appreciated.

Cheers


« Last Edit: April 04, 2010, 04:03:57 PM by angusmac »
Logged

Smyle1

  • Level 1 Member
  • *
  • Posts: 14
Re: uPNP DLNA 2104 error
« Reply #1 on: April 04, 2010, 05:43:20 PM »

Yes, this is a known issue and from what I was told it will be fixed in the next firmware release.

I am using Mediatomb to allow the MP4 functionality to stream to my PS3 until the firmware is released.

If you do a search in the forum on this issue, you will see my thread.
Logged

angusmac

  • Level 1 Member
  • *
  • Posts: 9
Re: uPNP DLNA 2104 error
« Reply #2 on: April 04, 2010, 05:57:42 PM »

Yes, this is a known issue and from what I was told it will be fixed in the next firmware release.

I am using Mediatomb to allow the MP4 functionality to stream to my PS3 until the firmware is released.

If you do a search in the forum on this issue, you will see my thread.

Thanks Smyle.

I was tending in that direction but was concerned that installing the funplug apparently invalidates warranty etc.  I was also concerned about the 2104 error as I haven't been able to find a lot of information on this, what exactly it was caused by and / or how to fix it.  Before I took the plunge with Mediatomb I wanted to make sure that it was actually the solution.

Cheers
Logged