• November 19, 2019, 05:08:25 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Experience with tech support  (Read 2466 times)

weirdo

  • Level 1 Member
  • *
  • Posts: 2
Experience with tech support
« on: October 08, 2009, 05:50:02 PM »

There are many unhappy threads here so I will provide my so-far happy experience.

I bought a working unit from Ebay but while attempting the firmware change the unit became unresponsive.  After calling tech support, it was determined that the unit was completely dead.  Tech support kindly gave me a RMA number.  I shipped the unit back recently and today I received a tracking number for the new unit being shipped to me :)

Also, while waiting, I bought a PS3 because I missed PlayOn and also wanted a bluray player.  Let me tell you the PS3 sucks when it comes to interfacing with PlayOn.  I have the most current firmware in the PS3 and it does not work more often that it does.  It keeps reporting a 2006 mlna protocol error.  It is just awful I don't know what I'm going to do with it.  I'm not into games so I have a problem with having a $300 blue ray player.
Logged

tybucks

  • Level 1 Member
  • *
  • Posts: 3
Re: Experience with tech support
« Reply #1 on: October 15, 2009, 09:46:21 PM »

Looking to sell the PS3??  ;)
Logged

weirdo

  • Level 1 Member
  • *
  • Posts: 2
Re: Experience with tech support
« Reply #2 on: October 20, 2009, 11:45:06 PM »

haha I might as well keep it.  I'm figuring it will have a upgrade someday soon which will mean if the PS3 or the DSM-520 is on the fritz, at least I will have a backup system.  In addition, it has a hard drive so I'm thinking in addition to a bluray player it might also serve as a DVR.  I am not sure yet, who knows.  When I have time I will explore this PS3 and see what it can do.

But anyway I just wanted to follow-up to say that I did receive a new DSM-520 from Dlink.  They were willing to ship me a new one to replace the one that I got on Ebay and messed up after it stopped responding in the middle of a firmware upgrade.  I figure that any other company would have told me to get lost and I was fully prepared to be told that in light of the fact that the unit was working when I received it and also due to the fact I got it on Ebay and also because everyone else here seems to have bad experiences with Dlink.  However, Dlink totally hooked me up so at least they earned me as a loyal customer.  I just figured I'd report my positive experience to sorta offset the bad comments I read here.
Logged