• November 30, 2020, 12:30:39 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Slow speeds compared to ISP's router  (Read 672 times)

jtannous

  • Level 1 Member
  • *
  • Posts: 2
Slow speeds compared to ISP's router
« on: October 25, 2020, 07:14:29 AM »

Hi,

I own DIR-878 router of yours running the latest firmware (1.30). The router is connected to my ISP's modem which is running in Bridge mode.

My ISP speed is 500Mb/s down, I confirmed that by connecting directly to the ISP's modem.

Recently my speed through the router won't go past 120Mb/s even though I changed nothing. Tried rebooting both the router and the modem multiple times, I even tried to factory reset the router but nothing helped.

I tried swapping the cable between the router and the modem to a CAT7 one, didn't help.

For the record: I connected my computer directly to the modem and I confirmed that I get full 480~ Mb/s there, while max 120Mb/s through the router (using a cable).

I'm out of ideas.
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49371
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Slow speeds compared to ISP's router
« Reply #1 on: October 25, 2020, 09:22:10 AM »

Link>Welcome!

  • What region are you located?
  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?
  Link> >FW Update Process
  • Was the router working before any firmware updates?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

jtannous

  • Level 1 Member
  • *
  • Posts: 2
Re: Slow speeds compared to ISP's router
« Reply #2 on: October 25, 2020, 01:39:25 PM »

itís not related to the upgrade process itself. I upgraded my firmware about two months ago and everything worked fine till two days ago. So the reboots and reset are not related to the firmware upgrade.

My router region is USA, However I live in Israel.

ISP is cable I guess, itís surely not DSL.

I saw that there is a few posts from recently regarding slow downs in DIR 878.
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49371
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Slow speeds compared to ISP's router
« Reply #3 on: October 26, 2020, 08:19:27 PM »

Well sees like if the router had been working with the recent FW update and now its not, possible issue with the ISP side or there maybe a wifi interference issue as well.
A factory reset and setup from scratch should be performed to test this with the router.
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

centaurius

  • Level 1 Member
  • *
  • Posts: 3
Re: Slow speeds compared to ISP's router
« Reply #4 on: November 21, 2020, 04:27:04 AM »

Hello,

I am having the same exact problem.

I have tried factory reset using firmware 1.30 and firmware 1.20 and the LAN speed through ethernet port (RJ45) wont go pass 120 MB/s barrier, when my ISP router delivers 200 MB/s when i connect to it directly.

If I enable QOS engine i get 120-130 MB/s, without QOS engine enabled I am around 100-110 MB/s. I have tried Lan port connections speed in "Auto" and "1000 Mbps" mode, same results: it wont go past 130 MB/s through cable connection. I tried to turn off wireless output of 2.4 GHZ and 5 GHZ band didn't help either.

I have also tested the Wireless speed using band 5 GHZ and through Wireless 5 GHz i can get 200 MB/s through the dlink  dir-878 router, so the problem is not the WAN port connected to ISP router. It seems to be something with the output in the RJ45 ports of the router.

Not sure what else I can try at this point. Any advise is welcome.
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49371
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Slow speeds compared to ISP's router
« Reply #5 on: November 21, 2020, 10:09:24 AM »

Link>Welcome!

  • What region are you located?
  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?
  Link> >FW Update Process
  • Was the router working before any firmware updates?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Hello,

I am having the same exact problem.

I have tried factory reset using firmware 1.30 and firmware 1.20 and the LAN speed through ethernet port (RJ45) wont go pass 120 MB/s barrier, when my ISP router delivers 200 MB/s when i connect to it directly.

If I enable QOS engine i get 120-130 MB/s, without QOS engine enabled I am around 100-110 MB/s. I have tried Lan port connections speed in "Auto" and "1000 Mbps" mode, same results: it wont go past 130 MB/s through cable connection. I tried to turn off wireless output of 2.4 GHZ and 5 GHZ band didn't help either.

I have also tested the Wireless speed using band 5 GHZ and through Wireless 5 GHz i can get 200 MB/s through the dlink  dir-878 router, so the problem is not the WAN port connected to ISP router. It seems to be something with the output in the RJ45 ports of the router.

Not sure what else I can try at this point. Any advise is welcome.
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

centaurius

  • Level 1 Member
  • *
  • Posts: 3
Re: Slow speeds compared to ISP's router
« Reply #6 on: November 22, 2020, 06:13:29 AM »

Hello,

Regarding the questions:

    What region are you located? - EUROPE, I think this is irrelevant for the problem reported
    Was a Factory Reset performed before and after any firmware updates then set up from scratch? - YES with FW 1.20 and FW 1.30 => SAME results

  Link> >FW Update Process

    Was the router working before any firmware updates?
- YES

Internet Service Provider and Modem Configurations

    What ISP Service do you have? Cable or DSL?
- I have CABLE, and again I think this is irrelevant for the problem reported
   What ISP Modem Mfr. and model # do you have? - Arris TG2492
Logged

centaurius

  • Level 1 Member
  • *
  • Posts: 3
Re: Slow speeds compared to ISP's router
« Reply #7 on: November 23, 2020, 11:56:28 AM »

So the issue seems resolved after a restart of the ISP router.

After disabling QOS engine and forcing WAN port to 1000 mbps instead of AUTO, I was able to get the full ISP speed in another computer (through the router) either wired or wireless (5 GHZ band). My main computer still reported 200 mbps through ISP router and 120-130 mbps through router... I think what resolved this was a restart of the ISP router AFTER the firmware update, since I hadn't done any restart in the ISP router when I tried FW 1.20 or FW 1.30 before.
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49371
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Slow speeds compared to ISP's router
« Reply #8 on: November 23, 2020, 09:14:30 PM »

Glad it's working now. Enjoy.  ;)
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.