• August 05, 2020, 07:44:08 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DCS-933L does not work  (Read 279 times)

dcsuser1234

  • Level 1 Member
  • *
  • Posts: 4
DCS-933L does not work
« on: June 28, 2020, 04:33:05 AM »

 Recently my DCS-933L camera does not work anymore (works well for 4 years).  The symptom is:
After I plug in the power cable,
1. The red LED (power) and the blue LED (wps) on camera's back both turn on.
2. After >10 seconds, both red LED and blue LED blink for serveral seconds, then both turn off.
3. After a while, the red LED turns on, meanwhile a IR-CUT clicking sound is heard.
4. The IR-CUT clicking sound happens 2~3 times again while the red LED keeps on.
5. Then the red LED turns off.
6. Soon step 1-5 are repeated.

I tried both wired and wireless connections, but neither works. In my router management, I did not see any assigned IP address to the camera.

I did not perform any firmware upgrade recently.

Then I followed steps described in https://eu.dlink.com/uk/en/support/faq/cameras-and-surveillance/dcs-series/dcs_recovery_procedures_after_bad_flash_firmware to perform emergency recovery.

It works however, as my computer can access the emergency webpage at 192.168.0.20. I then uploaded the latest firmware DCS-933L_A1_v1.15.01.bin.

But the symptom continues. Still the camera is unable to function. Still step 1-6 described above happens.

Anyone could help? Thanks.
Logged