• September 25, 2020, 04:07:12 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DWA-548 Wireless N incredibly slow  (Read 894 times)

GiantEwok

  • Level 1 Member
  • *
  • Posts: 1
DWA-548 Wireless N incredibly slow
« on: April 16, 2020, 08:58:32 AM »

Howdy folks,
So I'm running on Windows 10 64bit on a desktop.
Router is a TP-link Archer AC750 Wireless Dual Band.
Line Speed on test is about 52 down, 6 up.
I have a phone & laptop able to connect to the WiFi with no issue in the same place.
I have tried manually updating the drivers by downloading them off the d-link website but the PC is saying they are up to date, version 5.0.52.0 showing on the deets page when I check the device manager.
The d-link manager program is showing my signal strength at +/- 82% showing full green bars.
I understand that this adapter can only pick up the 2.4 band, not the 5.
Now the issue:
My internet has become incredibly slow when using the adapter. Timing out on google search slow. It shows I am connected & have access but whenever I try to do something it has a heart attack.
I have resorted to using my smartphone's WiFi as a short term solution, using the USB tethering function, connecting to either band at which point the internet is runs fine.

Has anyone run into similar issues or knows a better way of debugging?
Please let me know, losing my mind here
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49209
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWA-548 Wireless N incredibly slow
« Reply #1 on: April 16, 2020, 09:29:23 AM »

What happens if you fully remove the adapter drivers from Windows 10, uninstall them. The go back in and install the newer drivers.
What is the distance between the DWA and main host router?
Does your wifi router have any smart connect enabled?
Any beam forming or mimo options?
Try setting 40Mhz coexistence on the wifi router.

Can you test the adapter at a different location with a different router or with a different wifi router.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!