• August 05, 2020, 09:56:53 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DWA-192 - Ping Spikes - Troubleshooting  (Read 937 times)

war4peace

  • Level 1 Member
  • *
  • Posts: 1
DWA-192 - Ping Spikes - Troubleshooting
« on: January 26, 2020, 03:13:10 AM »

Hi all,
I own a D-Link DWA-192 which works well except for one thing: while connected to Wireless, I experience ping spikes at semi-regular intervals. I started investigating this seriously since it badly interferes with my need for constant connectivity.

Hardware:
- Router: Ubiquiti ERPoE5
- Access point: Ubiquiti AC Pro
- Wireless Adapter: D-Link DWA-192.
- Operating System: Windows 10 Pro (used 1803, 1903, 1090, issue manifested on all OS versions)

In order to narrow down the issue, I have used psping64, Process Monitor and Windows Powershell combined to obtain the exact timestamp at which ping spikes occur, then compare against timestamps recorded in Process Monitor.
The Powershell script I used for pinging my router very quickly is shown below:

Code: [Select]
.\psping64.exe -t -i 0 192.168.2.1 |Foreach{

 $pingsize = [double]($_ -replace "(.+:\s)|(ms)","")


 if ($pingsize -gt 100)
     {
     $adddate = Get-Date -Format "yyyy/MM/dd HH:mm:ss:fff"
     "{0} - {1}" -f ($adddate),($pingsize)
     }
 else {}
 } | Tee-object -FilePath ping_log.txt

What the script does is it runs PSPing64.exe tool repeatedly at maximum pace, adds a timestamp to the output with milliseconds and records only pings which have a response time greater than 100ms. Usually the response time from my router is between 1 and 2 milliseconds, the only exceptions being the ping spikes.

I have noticed the ping spikes occurring in pairs, at every 30 minutes (although sometimes they show up every 5 minutes).
Example output below:

Code: [Select]
2020-01-26 11:12:40:556 - 2853.58
2020-01-26 11:12:42:933 - 112.51
2020-01-26 11:42:40:819 - 2891.12
2020-01-26 11:42:43:376 - 115.8
2020-01-26 12:12:41:093 - 2893.87
2020-01-26 12:12:43:826 - 115.25

You can see there is a pair of spikes every 30 minutes, roughly 2.5 seconds apart. First spike is really large, almost 2900 milliseconds, while the second is smaller at about 112-115 milliseconds. I took those timestamps and checked them against Process Monitor output, narrowing the issue down to one active file showing up every time the issue occurs. The name of the file is SwUSB.exe.

This is a Realtek-provided file. The file version in properties is 500.1038.1209.2016, size is 489 KB (500,736 bytes) and it's digitally signed by Realtek on ‎Friday, ‎December ‎9, ‎2016 11:28:26.

I have also provided the list of events captured for SwUSB.exe at the moment the ping spike occurred. The USL to access is here:
https://docs.google.com/spreadsheets/d/1PjePnfN0FPheXcI8gGnhtp5qKp2DAJAh8tDA7lk3gPc/edit?usp=sharing

I hope the data I have provided helps identify and fix the root cause for this.
For now I have resorted to a rather primitive fix: I renamed the .exe file - will see if any ping spikes re-occur.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49031
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWA-192 - Ping Spikes - Troubleshooting
« Reply #1 on: January 26, 2020, 11:51:24 AM »

Link>Welcome!

  • What region are you located?

Have you tried this with a different wifi AP or wifi router?

There is new D-Link driver available just about 2 weeks ago:
Version: 1.08b03 Hardware: A1 Date: 2019/Nov/29 Driver:  Windows 7 x86  1030.25.0701.2017(WHQL passed) Windows 7 x64  1030.25.0701.2017(WHQL passed) Windows 8 x86  1030.12.0526.2016(WHQL passed) Windows 8 x64  1030.12.0526.2016(WHQL passed) Windows 8.1 x86  1030.25.0701.2017(WHQL passed) Windows 8.1 x64  1030.25.0701.2017(WHQL passed) Windows 10 x86  1030.37.0703.2018(WHQL passed) Windows 10 x64  1030.37.0703.2018(WHQL passed)

Problems Resolved:
N/A

Enhancement:
Win10 WHQLed drivers for WPA3.

I'm currently using driver version 1030.27.425.2018 and not seeing this issue. I'll let a ping run for a while and see if I notice anything.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49031
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWA-192 - Ping Spikes - Troubleshooting
« Reply #2 on: January 26, 2020, 01:36:32 PM »

So I set my Windows 10 x64 PC connected with my 192 adapter and send ping to -n 1000 and left. I came back later and found two entries:
Reply from 192.168.0.85: bytes=32 time=2465ms TTL=64
Reply from 192.168.0.85: bytes=32 time=1993ms TTL=64
There was a long period in between these two entries, and all other entries were low single or low double digits. These were the only two high (ms) times recorded for the 1000 count ping.

Wireless is a NetGear Orbi RBR850 in AP mode.

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!