D-Link Wireless Routers for Home and Small Business > DIR-842

DIR-842 Weird Behaviour

(1/2) > >>


My DIR-842 is acting up all of a sudden.  HW version B1.

We noticed the problem when our phones could not connect to the wireless network they normally see.  The router's wireless network light was turned off.  Also, a PC that was hard-wired into the router could not access the router login page over, and was seeing a windows default IP when using ipconfig, indicating a failed DHCP request to the router.

The router also did not have the internet light on, even though the internet LAN cable was plugged through to the modem (which is operating in bridge mode).

I verified that bridge mode was still functioning properly, and I plugged the modem directly into the PC and that was fine.  I tried using another PC to access the router and failed to get an IP address assigned also.

I reset the router by holding down the factory reset button.  During this time, the router power light started blinking repeatedly.  I saw that this indicates a possible hardware failure.  I turned the router off for a few minutes, then turned it back on again.

The wireless light came back on, and had reset to the standard dlink-### SSID.  I tried connecting with my phone, and ended up on the router login page but it just said "Please Wait", and nothing happened.  After a few seconds, the SSID failed to connect anymore.

I plugged in a laptop via LAN cable to one of the PC ports on the router.  Strangely, the network ID was the old name that I had assigned (even after doing a factory reset).  I was able to get an IP address and go to the login page, where I was greeted with the first-time setup prompts (plug in your internet cable, choose a name and password for the networks, etc).  After, the router tried to reset itself to save the changes.  This is when stuff started to fail again.

The laptop said it had an ip address of, but could not access to get to the login page.  Also, the internet was not accessible through LAN, and the WIFI SSID was not showing up at all.  All of the right lights on the router were lit up (Power, Internet, Wifi, PC 1).

Anyone else run into a weird issue like this?  I'm afraid maybe the hardware is just fried or something.  It's been in continuous operation for a year and 7 months, haven't had any problems before now.

I want to try updating the firmware but I can't since I can't consistently access the login page.

Thanks for reading,



* Link>What Firmware version is currently loaded? Found on the routers web page under status.
* What region are you located?
* Has a Factory Reset been performed?

Internet Service Provider and Modem Configurations

* What ISP Service do you have? Cable or DSL?
* What ISP Modem Mfr. and model # do you have?


I will try to find the firmware version later, but I could not access the router's webpage consistently so I am unsure right now.

I am located in North America.

I have tried a factory reset, but as noted above, it had some weird behaviour (Wireless SSID was reset, but LAN Network name was still present, router presented setup dialogues but then stopped working).

ISP: Cable
ISP Modem: Hitron CGN3



Something to try with current version of FW or maybe step back one version to see if you can get the router to a stable state again:
Emergency Recovery Mode

Let us know if this doesn't work...


So I managed to get into the router temporarily using a static IP address.  Found it was firmware version 2.02, dated 6/14/2016.

I tried upgrading it to 2.02, dated 6/24/2016, it said upgrade successful.  I used Firefox to do this.

However, after the router rebooted, I was no longer able to get into the router page (connection would time out or be refused).

I used the Emergency Flashing procedure and got the recovery page.  Uploaded the same 2.02, dated 6/24/2016.  It said success.  I also used Firefox to do this.

When the router restarted, I was no longer able to access the router page (connection to would time out or be refused).  Also, monitoring my network status, it seemed that the router was rebooting itself continuously every 10-12 seconds or so.  The network cable would show as disconnected, and then reconnect.

The LEDs that would light up were: Power, LAN 1 through 4.  Then LAN 1-4 would turn off, and LAN 1 would light up (connected to PC).  After a while, the wireless LED came on too.  After 10 seconds, it would flash all the LAN lights again, like it was booting, and repeat.


[0] Message Index

[#] Next page

Go to full version