• May 19, 2019, 05:52:43 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: App crashes on iPhone iOS12  (Read 342 times)

Al4

  • Level 1 Member
  • *
  • Posts: 3
App crashes on iPhone iOS12
« on: April 25, 2019, 04:49:43 AM »

I have version 1.1.7 of the D-Link WiFi app installed on iPhone XR (iOS 12.2), when I open the app it says 'Detecting Device' for a while, it then goes to a round image with scroller looping around it and then after a few seconds it just exits to a black screen. Open the app again and the same thing happens.
I have tried removing the app and installing from scratch but the same thing happens - any ideas?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47368
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: App crashes on iPhone iOS12
« Reply #1 on: April 25, 2019, 06:35:28 AM »

Try removing the app, power OFF the iphone, then back on then re-install.
Which model iphone do you have?

It's working on my 6sP phone...
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Al4

  • Level 1 Member
  • *
  • Posts: 3
Re: App crashes on iPhone iOS12
« Reply #2 on: April 26, 2019, 12:50:36 AM »

I did the re-install after restarting but still see the same problem:

 - The app starts, showing 'Detecting device'
 - It sees my COVR base and it prompts me to login to manage
 - I enter the password, it goes to the universe image with scroller running around it
 - After a few seconds the screen goes black & the app goes to back ground
 - Opening the app again shows 'Detecting device' and goes around in that loop

I have an iPhone XR with iOS12.2 (it worked fine on my iPhone 7)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47368
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: App crashes on iPhone iOS12
« Reply #3 on: April 26, 2019, 06:34:02 AM »

What COVR model do you have?
FW version on the COVR?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47368
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: App crashes on iPhone iOS12
« Reply #4 on: April 28, 2019, 08:53:06 AM »

Ok, I see the same issue. After putting my COVR1203 online yesterday, I see the app is detecting then I get the white spinning circle page then it closes. Never opened no matter how many times I try.  :-\ I tried from my Android data pad and it works. So something is broke on iphone and the app. I'll pass this on to D-Link for review.  ;)

Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Al4

  • Level 1 Member
  • *
  • Posts: 3
Re: App crashes on iPhone iOS12
« Reply #5 on: April 29, 2019, 05:38:29 AM »

That's good, thank you
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47368
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: App crashes on iPhone iOS12
« Reply #6 on: April 29, 2019, 06:40:33 AM »

What COVR model do you have?
FW version is on the COVR?

I did the re-install after restarting but still see the same problem:

 - The app starts, showing 'Detecting device'
 - It sees my COVR base and it prompts me to login to manage
 - I enter the password, it goes to the universe image with scroller running around it
 - After a few seconds the screen goes black & the app goes to back ground
 - Opening the app again shows 'Detecting device' and goes around in that loop

I have an iPhone XR with iOS12.2 (it worked fine on my iPhone 7)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting