The Graveyard - Products No Longer Supported > DIR-655

Accidentally updated my firmware to 1.37NA


Hi All,

I am really hoping my mistake isn't permanent.

I accidentally upgraded my DIR-655 version to 1.37NA which removed the feature allowing the USB port to be used with 3G, this is a feature I desperately need.

Unfortunately my device is using hardware A4 (according to the login screen) and hardware A5 according to my serial. This means I do NOT have the emergency firmware recovery mode.

I have tried to install the WW & EU versions of 1.37 firmware and all I get is a "you do not have permissions blah blah blah". And then it simply says that the file is either corrupt or the router is busy. BUSY the router is factory defaulted and has no internet connection, whats it busy doing... please help? Either a way to get past the NA firmware 3G lockout or a way to put another firmware on it?

Kind Regards


* What region are you located?
What FW version did you have loaded on it prior to v1.37?
Try to simply downgrade to that prior version?

I presume if 1.37 is loaded and it won't downgrade, you maybe stuck there.  :-\

I am located in the UK, so not North America.

Previous version was below 1.16 I think, I really wish I had made a note of it and perhaps checked the change notes.

I have tried almost every version of firmware I can get my hands on with no luck, I really hope this doesn't mean I am stuck, surely there must be a way to move from an NA version to the UK/EU/WW version somehow...
 :-[ :-\ :'(

Ya I remember there being someone who posted about getting back from NA FW to EU FW. You can do a search in the EU forum and see if you can find that post. Been a long time though.

Ya, if you can't get back to EU, I'm afraid your stuck.


[0] Message Index

Go to full version