• May 24, 2020, 07:11:35 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]

Author Topic: D-Link Portal no longer works with Safari 12  (Read 7592 times)

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: D-Link Portal no longer works with Safari 12
« Reply #15 on: January 14, 2020, 02:48:31 PM »

Ok, just got home and used FF ESR v52.9.0 64bit version of there browser on my Mac Book Pro 2018 OSX 10.14.6. FF first presented me with a block or accept message after I logged into the mydlink.com portal. I presume this is about the plug-in. I selected ALLOW and Remember. The plug in loaded and I saw 5 devices, 3 cameras and 2 routers. My DCS936L, 960L and 933L appeared. I was able to select all three and view the video coming from each camera.


I have to post a problem with the 960L that is generating a ticking sound coming from the camera when I enable the microphone. Goes away when I disable it. The other two cameras don't do this.
« Last Edit: January 14, 2020, 02:57:46 PM by FurryNutz »
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

trapandclay

  • Level 1 Member
  • *
  • Posts: 11
Re: D-Link Portal no longer works with Safari 12
« Reply #16 on: January 14, 2020, 02:58:22 PM »

OK, thanks. It is working on my iMac 10.13 with FF, but the "manage plug-in use" icon is not showing up on the left side of the address bar. I sure hope there is a setting in FF to allow the plug-in to work.

RK
Logged

trapandclay

  • Level 1 Member
  • *
  • Posts: 11
Re: D-Link Portal no longer works with Safari 12
« Reply #17 on: January 14, 2020, 03:04:57 PM »

Ok, thats good !  I must need to find FF ESR v52.9.0 since I am using FF ESR 52.0 (which I got from a thread on this forum Posted by GreenBay)

Hope I can find it and duplicate what you have working there.

Many Thanks,

RK
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: D-Link Portal no longer works with Safari 12
« Reply #18 on: January 14, 2020, 03:17:00 PM »

Heres the main repo for v52.9.0 for all platforms:
http://archive.mozilla.org/pub/firefox/releases/52.9.0esr/
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

trapandclay

  • Level 1 Member
  • *
  • Posts: 11
Re: D-Link Portal no longer works with Safari 12
« Reply #19 on: January 14, 2020, 05:26:40 PM »

Thanks alot, I'll give it a try !

RK
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: D-Link Portal no longer works with Safari 12
« Reply #20 on: January 15, 2020, 06:55:10 AM »

 ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

trapandclay

  • Level 1 Member
  • *
  • Posts: 11
Re: D-Link Portal no longer works with Safari 12
« Reply #21 on: January 15, 2020, 03:51:14 PM »

Hello FN,

Well,,,,,,,,,,,,,,,52.9 loaded just fine,,but,,the plugin would not load regardless of what I did. Even tried a 51.0 load, same thing, "plugin install failed".

After about 15 of those messages following every adjustment I could think of, I went hunting for another solution. Now, getting late into the AM hours, I located directions for a "manual" plugin loading sequence. Was hoping to find something you could use and return the favor but you seem to be running just fine. Instead, I'll post the link here and forward the favor to those who can't get the Uplayer to install. Looks like it comes from the Brits on a Dlink site designed for iOS 10.12 but the great thing is, it worked great on my MacBook 10.14. Probably a simple solution for most but for a lot of us who are still learning the Mac systems it was a real nice find for me. Hopefully this will help some others back to using their cameras on Macs again.

It worked on the FF 51.0 so I loaded the FF 52.9 again and then followed this sequence:

https://eu.dlink.com/uk/en/support/faq/cameras-and-surveillance/mydlink/how-to-install-mydlink-plugin-on-mac-os-10_12

It worked there too, and still working great this morning.

1. Load FF 52.9 and "immediately" disable the auto update in preferences / advanced / update. (otherwise FF will go to 69.0)
2. Follow the steps on the link above and everything starts working with access to the "manage plugin" icon on the address bar.

I believe there is a thread on here for all the Uplayer install problems, hopefully this info will help some of those folks get mydlink working again.

Thanks again,

RK

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48789
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: D-Link Portal no longer works with Safari 12
« Reply #22 on: January 15, 2020, 05:06:47 PM »

Sounds like you got it working.

Enjoy.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!
Pages: 1 [2]