D-Link IP Cameras for Home > DCS-936L

Problem with DCS 936L ?bad firmware


Dear all,

I've bumped into a serious problem. My 936L is not connecting to the wifi. I tried to reset it by pressing the reset button for 10s. The LED turns from solid red to flashing but as long as I release the reset button, the LED becomes solid red again. I can't get it to reset. The camera SSID cannot be detected.

Is there a way to flash the firmware manually? My warranty has expired.

Tried this webpage, but it does not show the instructions for DCS-936L model.


I would truly appreciate your help. Thanks a lot!


* What region are you located?
What Mfr and model is the main host router?
What wireless modes are you using?

Did the camera get updated with the new FW?

Is the mobile app and mobile phone able to see the DCS wifi after the reset?

Thanks FurryNutz!

I got the camera back to D-Link and they couldn't fix it as they couldn't even get it to broadcast a SSID. They decided to get me a new one.

Glad you got a new one. Enjoy.


[0] Message Index

Go to full version