• October 15, 2019, 05:41:43 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DNS-320L wifi speed windows 10 slow!  (Read 496 times)

jumpingjackflash5

  • Level 1 Member
  • *
  • Posts: 4
DNS-320L wifi speed windows 10 slow!
« on: August 15, 2019, 01:15:12 AM »

Hello,

I have slow download speed (2-3 MB/s) and fast upload speed (5-6 MB/s) on DNS-320l share over Wifi.
I tried all the settings.
The only things that resolves this is to set manually 100 Mb/s connection speed, although NAS is connected to gigabit switch/router  (DIR-655, BTW).
In this case the connection speed is symmetric, 5 MB/s both. But in this scenario the access speed from wired computers is 100 Mb/s only.

Can anything be done with it ???
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS-320L wifi speed windows 10 slow!
« Reply #1 on: August 15, 2019, 06:14:59 AM »

ink>Welcome!

  • What Hardware version is your DNS? Look at the sticker behind or under the device.
  • Link>What Firmware version is currently loaded? Found on the DNSs web page under status.
  • What region are you located?

Try putting a D-Link DGS-105 or 108 Gb switch in between the DIR an DNS. Connect the DNS and wired PCs to this switch.
What Rev # is the DIR router? What FW version is loaded on it?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jumpingjackflash5

  • Level 1 Member
  • *
  • Posts: 4
Re: DNS-320L wifi speed windows 10 slow!
« Reply #2 on: August 15, 2019, 11:51:00 AM »

Hello thanks for reaction!
I have the latest firmware 1.11
I live in Europe Czech republic
I dont know the revision but I do not think this is revision specific.
I can try to put another switch but it probably won't help. Because gigabit speed is ok on wired connection. I tried multiple access points but makes no difference. Only switching to 100 Mbit helps.
Dir 655 Is revision c firmware latest. 
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS-320L wifi speed windows 10 slow!
« Reply #3 on: August 15, 2019, 03:43:17 PM »

Are you doing a LAN to LAN xfer or a wireless to LAN/DNS xfer?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jumpingjackflash5

  • Level 1 Member
  • *
  • Posts: 4
Re: DNS-320L wifi speed windows 10 slow!
« Reply #4 on: August 16, 2019, 04:22:13 AM »

As I Wrote, the problem occurs only on wireless access to lan-dns 320l. I suspect that when manually set to 100mbit samba parameters are somewhat modified and this is fast on wifi.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47838
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DNS-320L wifi speed windows 10 slow!
« Reply #5 on: August 16, 2019, 06:11:55 AM »

And your using the 2.4Ghz wireless radio to connect to on the DIR router? If so, this maybe the bottle neck. You need to find out what connection rate your connecting at with the DIR router. You may want to get into a 5ghz wireless AP to add on to the DIR router. The 655 of this generation didn't have blazing speeds on 2.4Ghz.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jumpingjackflash5

  • Level 1 Member
  • *
  • Posts: 4
Re: DNS-320L wifi speed windows 10 slow!
« Reply #6 on: August 18, 2019, 12:45:11 PM »

Thanks. The problem is not in overall speed which is as expected 5 MB/s on WiFi. But with the asymmetric speed that occurs when gigabit ethernet Is enabled. I suspect some Network or samba setting. For example flow control or some buffers. But I do not know how to change it they are not exposed in UI.
Logged