• July 16, 2019, 02:59:39 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]

Author Topic: DWR-921 default password not working  (Read 13455 times)

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47562
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWR-921 default password not working
« Reply #15 on: April 10, 2018, 09:44:35 AM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.

Rev c1

update
Firmware Release notes included 3.00b07

Not working admin / admin or admin / (blank)

pls help me
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

GreenBay42

  • Administrator
  • Level 10 Member
  • *
  • Posts: 2111
Re: DWR-921 default password not working
« Reply #16 on: April 10, 2018, 10:01:09 AM »

The default username is admin (lower-case), password (leave the box blank - press delete/backspace to make sure no spaces or hidden characters are there). 

If you updated the firmware but did not reset it, your old password should work.

Reset again (hold paper clip in reset hole for 10 seconds and release) and try admin/blank. Contact tech support in your region if it continues to fail.

Logged

Guvner067

  • Level 1 Member
  • *
  • Posts: 1
Re: DWR-921 default password not working
« Reply #17 on: August 22, 2018, 07:25:41 PM »

Similar issue. Purchased the DWR-921 today. Can't update password from <blank> to a new password.
After "Apply". the page refresehes and takes me to the login scree. Enter <admin> and "new password".
Message "Invalid username or password" appears.
neither <blank> or "new password" works.
Have to reset router. Can log back in with admin/<blank>
Tried 4 ties with different "new password"
Each time same result. it's as though the router is storing a different password to the one I enter!
Firmware:  V01.01.3.005
Logged
Pages: 1 [2]