The Graveyard - Products No Longer Supported > DIR-655

Internet slow through DIR-655, and can't see new modem status page

(1/4) > >>


I've been runing a DIR-655 router, along with a cable modem.

* Wired connection
* I'm in the US
* H/W version is B1
* I just upgraded firmware to the latest before reaching out through this forum.

I'd like to ask about two separate issues:

1) When I run Speed Test with my modem directly connected, I see my normal high speed (~100Mbps), but if I run it through the DIR-655, it drops to the 37Mbps range. This being a gigabit router, I'd expect there to be zero issues processing this comparatively low rate, yet it cuts it down to like a third of what it should be. This is completely unacceptable. How do I fix it? I've found some anecdotes about this router being full of bloat that can be disabled, and in particular, "DNS Relaying" apparently is a big culprit. I tried disabling that, but then I wasn't able to connect to anything at all. Maybe I did it wrong.

2) I just changed my modem from an Arris SB6190 to a MB8600, and now I can't see the modem status page ( This address is the same as with my Arris, and when I tested with just the modem directly connected to my pc, it works just fine, so it's definitely the router doing something broken.

While you might be able to say "this is a crazy old router" for (1) (even though I don't buy it - I'm not exactly on the bleeding edge of speed here), there's no way you can say that for (2), since I'm just... literally trying to hit an address that WORKED with all my previous modems.

so... little help? Let me know what other info would be helpful here. Thanks!


* What region are you located?
* Link>What Firmware version is currently loaded? Found on the DNSs web page under status.
* Are you wired or wireless connected to the router?
* Was a Factory Reset performed before and after any firmware updates then set up from scratch?  Link> >FW Update Process

* Was the router working before any firmware updates?

Router and Wired Configurations
Some things to try: - Log into the routers web page at Use IE, Opera or FF to manage the router. Besure to log into the Admin account on the router.

* Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options, Advanced/QoS
* Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual or under Setup/PARENTAL CONTROL/Set to>None: Static IP or Obtain Automatically From ISP.
* Enable or Use Unicasting (compatibility for some ISP DHCP Servers) and test under Setup/Internet/Manual. Disable may help with speed performance on higher speed ISP services.
* Turn on  DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench and input new DNS addresses under Setup/Internet/Manual.
* Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting and maintain consistency for applications that need to connect as well as mapped drives.
* Ensure devices are set to auto obtain an IP address.
* If IPv6 is an option on the router, select Local Connection Only under Setup/IPv6.
* Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.
* Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules. Enable IPv6 Multi-cast Streaming for routers that have a Media Server option. Disable IPv6 Multi-cast Streaming if IPv6 or Media Server is not being used.
* Turn off WISH, and WPS under Advanced.
* WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed


--- Quote from: FurryNutz on June 24, 2018, 11:45:34 AM ---Link>Welcome!

--- End quote ---

This link is broken ("The topic or board you are looking for appears to be either missing or off limits to you.")

--- Quote ---
* What region are you located?
* Link>What Firmware version is currently loaded? Found on the DNSs web page under status.
* Are you wired or wireless connected to the router?
* Was a Factory Reset performed before and after any firmware updates then set up from scratch?  Link> >FW Update Process

* Was the router working before any firmware updates?
--- End quote ---

* Region: I guess you want more specific than "US" - Seattle.
* Firmware: The latest: FW2.12NAB01 (BETA) - 11/01/2014
* Wired, though same issue if I try with Wireless, and also tested the cable from the router to the modem by plugging directly with THAT cable - it's not the cable that's the problem.
* The firmware update did a factory reset as part of its update. Though the only custom setup I have is my wifi password setup.
* Router working before? It was working the SAME as before. The only reason I did the FW update is that I knew someone would ask for it. It didn't fix anything, and operates exactly as it did before.
DNS relay was already enabled, and I've tried disabling QoS before I registered here.

Note I'm only paying for 100Mbps, which is slow compared to gigabit. There should not be any tuning/optimization required to get that much from the router out of the box. If I need to turn features off because the router cpu can't keep up with 1/10th of its advertised throughput, then I seriously question the quality of this router.

What speed test site are you using?
How long have you had this router? Just new? Where did you get it from?
Not sure what you mean by "bloat". DNS relay is a necessary feature when dealing with scheduling and access control.

Try disabling DNS Relay, when you do this you have to reboot both router and ALL devices as the DNS changes thus DNS cache needs to be cleared.
You can manually input different DNS, I use and
Set Firewall settings to EndPoint Independent for both TCP and UDP.

Try a different PC to see if problem is the same across the board...
Also set WAN Port speed to 1000Mb instead of Auto.
Try one more factory reset and set up from scratch.

I presume this maybe either a mis-configuration of the router or a possible HW issue. This router has been around for a LONG time and has had little problems accept for minor FW growth issues. This router has been a solid work horse router for what it is. I have this same model and before my ISP upgraded my speeds, I was also on 100/3 and saw ZERO issues with it.

Thanks for the advice, I really do appreciate it. :)

Speed test site: Whatever google picks. I'll let you know when I get home. When I connect directly to the modem, I see it basically hit the 95-100 range, and when I connect through the router (tried 3 computers), it just kind of sits around 20-25.

How long have I had the router: June 2011, so a while. Never bothered to compare speed with just modem speed (or maybe I had slower service at the time).

The reason I brought up bloat is, I went looking at Amazon reviews for it, and one person mentioned a bunch of things, and in particular, that DNS relay cut the performance down to about a third of what it should be, which... is something I need to experiment with.

I'll also try setting the WAN port speed if I haven't already. If I set it to 1000mbps, will it still work with speeds below that? If so, why is there 'Auto' as an option? shouldn't it just be "as fast as possible, just get out of the way and let the modem/device communicate unimpeded" :)

Do you have some thoughts on the second issue? I switched my modem from an Arris to a MB8600, and while the modem's status address hasn't changed (still, I cannot access that through the router. I remember reading something about configuring the modem as a bridge or something like that, but haven't followed through with it yet... was focused on getting the speed right.

Thanks for the help!


[0] Message Index

[#] Next page

Go to full version