D-Link Wireless Adapters > DWA-131

Adapter fails to connect (Win7&10 / Belgium)

(1/2) > >>

Pringab420:
Hey,
My old Belkin adapter started acting up, so I bought a new one the DWA-131.
Drivers seem to install correctly and the device is properly recognized.
My modem appears in the list of available networks and I can try connecting to it.
I am 100% positive the password I provide is correct, and it looks like it's accepted.
So far, so good then. However connection fails almost immediately afterwards.
The prompt says: "Windows is Unable to Connect to [network name]"
Troubleshooting didn't help, though it does highlight connection has failed.
I have tinkered with every parameter imaginable from wireless mode to power supply, to no avail.
Uninstalling drivers entirely and trying another set didn't do the trick either.
My main desktop operates on Windows 7, but giving it a try on my Windows 10 laptop revealed the same problem.
This lead me to suspect there is some sort on incompatibility with the modem, a (Belgian) Proximus b-box3.
I find it difficult to believe however that an adapter I bought in Belgium would fail to function properly with one the country's most common modems.
Assistance would be greatly appreciated.
Thanks.

GreenBay42:
I assume other wireless devices work ok?

What type encryption are you using? (WPA2 / AES for example)?

Are you using Windows to connect to the wireless network or the D-Link software program? (do not use the dlink software).

Can you test your laptop on another wireless network?

Pringab420:
Thanks for your quick response.
My old adapter "works" okay insofar as it manages to connect to the network like it always used to, it just repeatedly disconnects after a few minutes (it's almost 10 year old). My laptop's PCI card works perfectly fine.
Encryption used is indeed WPA2 / AES. I do use Windows directly and not the provided software.
I should add that I have installed the "WPA2 Security (KRACK) Patch" available on D-Link technical support, but it didn't change a thing.

GreenBay42:
If you try your laptop with this adapter on another wireless network you can rule out issues with the adapter itself or compatibility issues with the bbox3.

Things to test:
1. Turn off any encryption on the bbox3 and see if the adapter connects. If it works ok, could be something with the encryption negotiation or password.

2. Do you use spaces and any "special characters" in your password? If so, maybe try only numbers and letters to see if it connects.

3. On the bbox3 in the wireless settings, make sure MODE is on 802.11b/g/n or anything with N since this wireless adapter is wireless N 2.4ghz.

4. Reboot the bbox3. It can sometimes magically fix things :)

Pringab420:
1. Just tried. It doesn't change anything beyond not prompting for a password.
2. Nope, no special character whatsoever.  I am 100% positive the password is correct.
3. Wireless mode is 802.11g/n.
4. Already tried; didn't help.

Navigation

[0] Message Index

[#] Next page

Go to full version