• August 03, 2020, 02:05:15 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Clients not recieving DHCP lease "Failed to obtain IP address".  (Read 5096 times)

Evilbones76

  • Level 1 Member
  • *
  • Posts: 6
Clients not recieving DHCP lease "Failed to obtain IP address".
« on: February 19, 2018, 04:42:52 AM »

Hello,

We have a DWC 1000 wireless controller, and multiple 3600 AP boxes, on our Windows Sever 2012 based network.  The AP boxes are "managed" by the WC, they have the same AP profiles set via the WC.   We have a separate W2012 server providing DHCP for our LAN.

Clients can get a DHCP lease when connecting via a wired connection. 
Clients can connect to the wireless when we assign a static IP address.
Clients connect to the wireless network (e.g, I put in the SSID password and it says "connected buy no internet access") but receive a .169 APIPA IP address.

I have no idea why this is happening.  It appears as if something is stopping the DHCP server from sending a DHCP lease to the clients via the DWL 3600 AP. 

Any ideas?   
Thanks

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49027
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Clients not recieving DHCP lease "Failed to obtain IP address".
« Reply #1 on: February 19, 2018, 10:02:58 AM »

I would review the user manual to see if there are any settings regarding DHCP relay or DHCP Forwarding services that need to be configured on the DWL if this model supports any of these features. Some APs have there own DHCP server which may need to be disabled if your trying to get DHCP IPs from a different source.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Evilbones76

  • Level 1 Member
  • *
  • Posts: 6
Re: Clients not recieving DHCP lease "Failed to obtain IP address".
« Reply #2 on: March 08, 2018, 04:15:44 AM »

I would review the user manual to see if there are any settings regarding DHCP relay or DHCP Forwarding services that need to be configured on the DWL if this model supports any of these features. Some APs have there own DHCP server which may need to be disabled if your trying to get DHCP IPs from a different source.

Hello FurryNutz (lol),

Sorry not gotten back to you sooner - been waiting for a DWC - 1000 RMA.   I have this setup now, all of my APs (all 40 of them) are connected and working.  The WiFi network seems to be running optimally in terms of throughput.   

So, the final issue is that non-statically assigned devices cannot get a DHCP lease from our DHCP server.    Computer units can get a DHCP lease, so there is no problem with our server/client setup.   The DHCP setting on the wireless controllers are disabled, and there does not seem to be any apparent setting thats needs to be enabled or disabled to allow DHCP requests to tunnel through the the DHCP server.    All DWL - 3600 AP devices are running in "managed" mode, in that they receive their SSID profile from the wireless controllers.

Note:  Non-statically enabled devices - that is devices that have not had a static IP address assigned - can connect to the wireless network, they just get a 169. IP addresses. 

Any ideas?
Thanks for your help

« Last Edit: March 08, 2018, 04:17:19 AM by Evilbones76 »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49027
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Clients not recieving DHCP lease "Failed to obtain IP address".
« Reply #3 on: March 08, 2018, 10:08:16 AM »

You'll need to make sure your server is configured correctly. I would check any scope configurations, any MAC handling filters that may prevent clients from getting a IP address, check any DHCP relay configurations as well. Seems like a DHCP service or configuration issue.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Evilbones76

  • Level 1 Member
  • *
  • Posts: 6
Re: Clients not recieving DHCP lease "Failed to obtain IP address".
« Reply #4 on: March 09, 2018, 12:20:53 AM »

You'll need to make sure your server is configured correctly. I would check any scope configurations, any MAC handling filters that may prevent clients from getting a IP address, check any DHCP relay configurations as well. Seems like a DHCP service or configuration issue.

Hi Furry,

Clients can connect via Ethernet just fine, and receive a full lease from the DHCP server.  All scope settings are correct.  WiFi clients do not receive a lease from our DHCP server when MAC address filtering is not turned off or on.   I have fully checked the DHCP server, the logs everything is setup correctly.   

The only thing I can think of, is getting Wireshark on one of the mobile devices and check the packets to see what stage of the process is failing?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49027
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Clients not recieving DHCP lease "Failed to obtain IP address".
« Reply #5 on: March 09, 2018, 02:20:21 PM »

Lets try that.

So is the clients connecting to the DWL and not getting any IP address thru it from the main server?

If the DWL is in standard AP mode with out any of its server features running it should just pass thru any and all traffic from the main server to clients...
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Evilbones76

  • Level 1 Member
  • *
  • Posts: 6
Re: Clients not recieving DHCP lease "Failed to obtain IP address".
« Reply #6 on: March 12, 2018, 12:53:00 AM »

Lets try that.

So is the clients connecting to the DWL and not getting any IP address thru it from the main server?

If the DWL is in standard AP mode with out any of its server features running it should just pass thru any and all traffic from the main server to clients...

Hey Furry,

Yes, thats exactly right - the DWL is in standard management mode - whereby it is managing the AP's, but that's it.  It should pass through all packets/traffic to the server, but something is stopping the DHCP lease assigning process. 

Strangely enough, about 2/10 times I can actually get a full DHCP lease.  If I find out what AP (we have 40 of them placed around the college) the device is connected to (installing some kind of Net Analyser app on said device), then once I have located that AP, if I do a power cycle on the 3600 AP, sometimes it will provide a lease.   But, the AP's are in manged mode, so again they are just meant to pass through all traffic. 

I will get Wireshark installed, so whats up..

Thanks for your help,

SK
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49027
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Clients not recieving DHCP lease "Failed to obtain IP address".
« Reply #7 on: March 12, 2018, 10:51:13 AM »

Ok, keep us posted. I presume that maybe there is a configuration issue with the DWL or something is happening with it.

I would also make contact with NG support and get more review on there side with this.

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!