The Graveyard - Products No Longer Supported > DIR-601

one secure website won't load with router (but used to), but will with modem


I just registered and this is my first post, so bear with me if I am not doing everything right.
I have searched these forums, found similar issues, but nothing to help me.

I have a DIR601  H/W=A1, F/W=1.00NA

I am using a laptop with Windows 10.
There is one secure website that will not load (just keeps spinning with white screen).  This just started about a month or so ago.
I never had problems before (been logging in to this website for years)
I have tried using Chrome and also Internet Explorer.

However, when I disconnect my router, and hook up my computer directly to the modem, I am able to get to the website, login and do my work.

I also tried to connect with my smartphone - and got an error - Net::ERR_cert_authority_invalid   - connection is not private - so it didn't connect.
I googled this and tried the below, still not working.  (did someone try to hack me?)

My date/time is ok.
I cleared my brower history, and also flushed the dns - because technical support had me change my ip address several times a few months ago.
I reset the router to default settings, then set up a secure connection changing the SSID.
Security type:   WPA-Personal
Network band:   2.4 GHz
Network channel:   6
IPv4 address:
IPv4 DNS servers:


What else can I try?


* What Hardware version is your router? Look at sticker under the router case.
* Link>What Firmware version is currently loaded? Found on the routers web page under status.
* What region are you located?

Internet Service Provider and Modem Configurations

* What ISP Service do you have? Cable or DSL?
* What ISP Modem Mfr. and model # do you have?
I would upgrade the FW on this router, its way out of date and last version for this Rev A is 2013:

Link> >FW Update Process

If this still fails, you may need a new DIR series router.

I didn't have any problems back in February, so it wouldn't be the firmware. (but I can still try it)
I don't recall how my security was set up when I initially installed the router, so I don't know if I set it up the same or not.
And this is the first time I tried it using my phone.   My isp is comcast - cable

Try the FW update then go from there...


[0] Message Index

Go to full version