The Graveyard - Products No Longer Supported > DIR-850L

IPv6 trouble

(1/3) > >>


My provider uses IPv6 with "Auto Configuration (SLAAC/DHCPv6)". Indeed, my DIR-850L B1 gets an IPv6 WAN Address (even if this is not very stable and I have to reboot a lot) but the router itself doesn't hand the IPv6 over to my computers (macOS 10.13.4 and Windows 10), thus I don't get IPv6 connectivity. I tried firmware 2.21B01 and 2.22B02.

What could be wrong?

By default the router should pass through IPv6 addresses to your devices that support it. Do other devices other than the 2 computers get an IPv6 address?

On the Windows computer make sure IPv6 is enabled. (windows key + R, type in ncpa.cpl, right-click your adapter and select properties). Make sure there is a check next to IPv6 and it is set to DHCP.

On the Settings > Internet > IPv6 page, what settings are enabled?

I made a little experiment: I disabled DHCP-PD and entered a fake LAN IPv6 Address. Immediately both computers got an IPv6 address from the router. But of course there won't be working connectivity with a fake LAN address. So yes, IPv6 is enabled on both machines, but the router seems not to be able to complete the necessary auto configuration based on the WAN address.

Under LAN IPv6 Address Settings, (with Enable DHCP-PD enabled), click Advanced Settings.

Enable Automatic IPv6... and Enable Automatic DHCP-PD in LAN should both be enabled.

What is your autoconnection Type set to?


--- Quote from: GreenBay42 on April 17, 2018, 02:05:51 PM ---Enable Automatic IPv6... and Enable Automatic DHCP-PD in LAN should both be enabled.

--- End quote ---

They are indeed both enabled.

I tried all 3 autoconnection types: SLAAC+RDNSS, SLAAC+Staless DHCP and Stateful DHCPv6. No one works.


[0] Message Index

[#] Next page

Go to full version