• December 06, 2019, 10:40:51 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Security Cam doesn't have permission to write.  (Read 488 times)

MrPie

  • Level 1 Member
  • *
  • Posts: 2
Security Cam doesn't have permission to write.
« on: April 10, 2018, 06:27:41 AM »

First of all, hello all. I've been trying to sort this little problem but to no avail, hence me making an account and asking you lovely folk.

I had a 320L and basically i'm trying to get my foscam security cam to upload images to the nas drive. So far i've managed to create and link a ddns using dlinkddns.com and i've linked it up with the nas successfully. On my Security cam i have input my ddns server name as well as the username and password i set up through the nas (account management) and it seems to connect fine. It just doesn't seem to have the permission to write any files onto it. Here are the settings i have in the security cam

and this is the error i'm getting when testing the connection.


On my router i've forwarded both port ranges 55536-55663 and ports 20-21 for the nas.

Any help will be appretiated!
Logged

MrPie

  • Level 1 Member
  • *
  • Posts: 2
Re: Security Cam doesn't have permission to write.
« Reply #1 on: April 10, 2018, 07:23:28 AM »

And as luck would have it. Turns out my security cam (foscam) started to upload when i hated ticked "report external IP in PASV mode" and for anyone in the future who also has the same problem. You need to create a folder called "snap" (without quotes) in your main directory so if you were saving it to Volume_1/SecurityCam your snap folder should be in Volume_1/  :)
Logged

GreenBay42

  • Administrator
  • Level 10 Member
  • *
  • Posts: 2249
Re: Security Cam doesn't have permission to write.
« Reply #2 on: April 10, 2018, 07:30:57 AM »

Glad you found the issue and thanks for posting the fix.
Logged