D-Link Wireless Routers for Home and Small Business > DIR-842

Wireless connection issues with iPhone

(1/2) > >>

HansTheHuman:
I bought the DIR-842 today. Followed the setup guide and established connected through cable without any issues.

My iPhone however wont connect to the Router.
As I just installed the DIR-842, I believe I have the newest firmware (going into Upgrade informs me there's nothing up update)

I can see the connection on the device, attempting to connect results in writing the password (I keep doublechecking the ones I created in the setup)
   But as soon as I finish this and try to connect it jumps back down with other available connections in the area, occassionally trying to reconnect and failing.

One of the troubleshooting steps I came across was using WPA2-Personal, but I cannot locate this within the router setup. Is this old information not available in newer firmware, or is this not a logical step to follow for the solution?

Best regards
Hans

GreenBay42:
What version iOS are you running?

Try disabling Wi-Fi security and see if you can connect. If you can, try using only numbers and letters in your wi-fi password and see if it connects.

If you can't connect with wi-fi security off, there is something else going on. The router is compatible with iphones so it is most likely a setting on the phone and/or router.

Do other wireless devices work?

FurryNutz:
Link>Welcome!


* What region are you located?
Disable Smart Connect as well and test.


Internet Service Provider and Modem Configurations

* What ISP Service do you have? Cable or DSL?
* What ISP Modem Mfr. and model # do you have?

--- Quote from: HansTheHuman on March 13, 2018, 01:41:16 PM ---I bought the DIR-842 today. Followed the setup guide and established connected through cable without any issues.

My iPhone however wont connect to the Router.
As I just installed the DIR-842, I believe I have the newest firmware (going into Upgrade informs me there's nothing up update)

I can see the connection on the device, attempting to connect results in writing the password (I keep doublechecking the ones I created in the setup)
   But as soon as I finish this and try to connect it jumps back down with other available connections in the area, occassionally trying to reconnect and failing.

One of the troubleshooting steps I came across was using WPA2-Personal, but I cannot locate this within the router setup. Is this old information not available in newer firmware, or is this not a logical step to follow for the solution?

Best regards
Hans

--- End quote ---

HansTheHuman:

--- Quote from: GreenBay42 on March 13, 2018, 02:01:42 PM ---Try disabling Wi-Fi security and see if you can connect. If you can, try using only numbers and letters in your wi-fi password and see if it connects.

--- End quote ---

This one worked, though it's not an optimal situation. But I can connect to it immediately.
- As for the other questions:
1) I have 11.2.1, so there's an update available I will get sorted tomorrow at work.
2) Unfortunately I dont have any other wireless device to check with.

And to FurryNutz:
I am located in Denmark, Europe

I am unfamiliar with Smart Connect, may I ask how to disable?

I have Cable plugged from the wall to the router.
I dont have a modem, but there might be one collectively for this block. I can investigate whether or not tomorrow as well.
- I never thought to check up on this, the internet worked for my desktop the second I connected the a cable from the internet plug.


GreenBay42:
Were you using non-letters/numbers for your wifi password?

Also the wifi password is case-sensitive.

Definitely upgrade iOS. I believe there were wifi connectivity issues with 11.2.1.

Navigation

[0] Message Index

[#] Next page

Go to full version