• February 24, 2021, 09:49:59 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: OpenVPN routing issues  (Read 3462 times)


  • Level 1 Member
  • *
  • Posts: 1
OpenVPN routing issues
« on: December 27, 2017, 06:36:05 AM »


I have problem connecting my DSR250N to OpenVPN as client with following configuration. I did the following steps to configure the router.

1. I loaded following certificates for authentication: ca cert, client cert, client key, tls auth key
2. I enabled openvpn in client mode and configured vpn server IP, encryption via AES-128 and auth through SHA256. I also enabled tls-auth option
3. I added my network to remote networks in OpenVPN configuration on the router
4. When i perform ping, on my dlink router to OpenVPN server, it works ok. When i ping from my openVPN server the VPN ip of the router, it works OK.
5. When i check active OpenVPN connections on my vpn server, i see the dlink router connection.
6. However, when i check active VPN connections on the dlink site, the list is empty.
7. Within the dlink router i can ping any public address via OpenVPN, however from within the local subnet i cannot ping or access anything.
8. Currently i run on firmware 2.11_WW. I tried upgrading to 3.11_WW with no difference. Additionally, the firmware 3.11_WW common is corrupted when i download it from your support website (i have to stay with the 3.11_WW intermediate).

What am i doing wrong? How am i able to establish OpenVPN tunnel between the router and my OpenVPN server?

- the certificates are ok, the connection is working ok from my pc with software OpenVPN client
- the lzo compression is disabled on the server side
- it looks like the VPN tunnel itself is working between the router and the OpenVPN server, however there is no traffic routed through it (and the tunnel is not shown in the active OpenVPN connections on dlink side)


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49520
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: OpenVPN routing issues
« Reply #1 on: January 02, 2018, 01:19:16 PM »


  • What Hardware version is your router? Look at sticker under the router case.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?
  • Has a Factory Reset been performed?
  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?
  Link> >FW Update Process
  • Was the router working before any firmware updates?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

What browser are you using with the DSR?

I'll ask about the Common file size vs Intermediate file size.
« Last Edit: January 02, 2018, 01:25:48 PM by FurryNutz »
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.