• May 27, 2018, 02:43:51 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]

Author Topic: PS4 Won't Connect to Wi-Fi and Router Will Not Downgrade Firmware with 1.02 BETA  (Read 2120 times)


  • Level 1 Member
  • *
  • Posts: 4

I upgraded to v1.10B05 without notifying my roommate to see if he encountered any issues. He asked me if I did anything with the router because his PS4 wouldn't connect anymore. I also noticed after upgrading that my Roku 3600R was no longer able to "see" the 5Ghz Wi-Fi network it used to be connected to. Neither in automatic scanning nor typing in the SSID like it was a hidden network would "see" it. No other settings were changed after upgrading to v1.10B05.

The link above says to follow the Emergency Mode to flash a lower firmware image and I tried that. Each flash attempt failed with Firefox and Internet Explorer erroring out saying that the connection timed out. I tried using v1.01B04 and v1.02B01 but neither would flash. I unplugged the router for a few minutes and tried again while holding the reset button for roughly 30 seconds during each step and tried v1.01B04 again. It appeared to flash but made zero progress over 10 minutes as the screen still showed the revolving circle and unplugged it for a few minutes. I tried flashing again but the router did nothing but flash the Power LED. I couldn't find the router running
Code: [Select]
ipconfig in PowerShell, and trying to access the Emergency Mode did nothing as well. All signs point to it being bricked and I'll be getting in touch with support for an RMA.


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 45015
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology

If this failed:
Emergency Recovery Mode

I would make contact with D-Link support and ask for an RMA. Sorry you have been having problems.
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting
Pages: 1 [2]