• April 02, 2020, 10:44:26 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Router Config for Wake on Wan -, Instructions.....  (Read 48913 times)

pfountain

  • Level 1 Member
  • *
  • Posts: 4
Router Config for Wake on Wan -, Instructions.....
« on: August 07, 2009, 06:59:22 PM »

Hi All….
As you can see for the following link http://forums.dlink.com/index.php?topic=6798.0 ,  I have been trying to get Wake on Lan, Wake on Wan (internet) working with my network.  I didn’t do much searching on this forum before my post not realizing that I was not the only one, but did after the responses. To be honest, I found the information marginally  helpful in getting my WOL working, however with perseverance, using this forum and other sources I finally got it to work. Since there were others that posted, I figure I will share how I got it to work in hopes that this shared info will be useful to others.  I know that some if not most of you will think that this is too basic and obvious, since you are much more advanced users, but for those like me who are not,  I am keeping the steps as simple as possible since complexity was one of my major frustrations.

To start, let me describe the h/w I am using….
My home network consists of a dlink router DIR-655 connected to a cable modem. I have Cox Communication ISP. I have a couple home built PCs, one I will be running as a vpn server – this was the one that I want to WOL.

Okay, so to get the WOL and WOW working I configured the systems in the following way….
1.   On the PC that I want to WOL/WOW, I made sure the motherboard’s (which has an integrated network card) Bios had Wake on Lan enabled in all parts of the BIOS.

2.   I am using XP and going into the network card’s properties through Control Panel>System>Hardware>Device Manager>Network Adapters right clicking properties on the network card, I made sure that a) Wake on Magic Packet had been turned on, Wake on pattern was enabled, Wake on Lan from poweroff was enabled,  and b) under the Power Management tool, all three items were checked (all the computer to turn off this device,  allow this device to bring  the computer out of standby, Only allow management stations….).

3.   Next, I setup my router with the proper configurations. I am running F/W 1.11. I got this to work with this version, not sure about follow on versions. 
a)   Under SETUP, I added a DHCP reservation for the computer I want to WOL. This will ensure that this computer will always have the exact same ip address on my LAN so that I can direct the appropriate commands to the PC for wake on lan.  (also for the vpn server functionality)
b)   I am using a series of ip addresses 192.168.XXX.YYY
c)   In the ADVANCED>VIRTUAL SERVER I added the following item: Name: Wake on Lan from the application list, IP address: 192.168.XXX.255  Port: 9 for both Private and Public  Protocol: UDP  17  Schedule: always  Inbound Filter: Allow all   >>>>IMPORTANT NOTES:  A couple things I want to point out. First off notice that the IP address is NOT the PC’s IP address, but rather ends in 255. I don’t completely understand the reason behind all of this, but enough said that when you send an instruction to this address ending in 255, the router will send it to all equipment connected to the Router. This was a major breakthrough moment for me when I finally got this through my thick head and realized I could route magic packets to this address.  As long as the ‘XXX” are the same as the ones for the network, the 255 address will work. Secondly, I tried using Port Forwarding. This did not seem to work for me. I most likely was doing something wrong, but since Virtual Server seems to be working and I only have 1 pc to WOL, this is fine.
d)   I had previously signed up for a DDNS (free on various sites) and made sure that this information was enabled and entered through TOOLS>DYNAMIC DNS
e)   Finally, I had gone to STATUS>DEVICE INFO and made sure I had written down the MAC address of the PC I want to WOL (at the bottom of the page, LAN computers getting the info the relates to pc with ip 192.168.XXX.YYY), and the IP address of my network (under WAN  IP Address) which is in fact the ip address assigned to the network by the ISP.

4.   I then went to the following website: http://www.depicus.com/wake-on-lan/. This has good information about WOL and a excellent tool that I decided to use. I downloaded the tool from http://www.depicus.com/wake-on-lan/wake-on-lan-gui.aspx.  After installing I was ready to test the WOL feature.

5.   My suggestion to all who are trying to do this is to first make sure the WOL works internally (within your own LAN) before trying to WOW. If you can get the pc to WOL from another PC on the network then you will be ready to try WOW.

6.   I put the PC I want to wake in Standby mode. Using my laptop connected to the network, I launch the Depicus WOL Magic Packet program. I used the following information: MAC address of the PC I want to wake, internet address: the pc’s ip address 192.168.XXX.YYY, subnet mask: 255.255.255.0 Send options: internet, Remote Port Number: 9. when you hit wake me up button you will get a message that the program send a magic packet to 192.168.XXX.255. If everything is configured correctly this will wake up the PC that is on standby.  NOTE: if you want to have a different port other than 9 than you can use any other number you wish as long as the Router port has been changed to match.

7.   Assuming that you have been successful at getting the PC to wake within the lan network you can try through WAN. For this I use the same WOL program but with the following information:  MAC Address: address of the pc (same as before), internet address: you can use EITHER the IP address of the network you wrote done in step 3E or use your DDNS address (i.e. myaddress.dyndns.com or whatever…) Subnet mask: 255.255.255.255 – NOTE THIS CHANGE THIS IS CRITICAL…if you leave it as in step 6 (255.255.255.0) the magic packet will NOT be sent to your network (this also was my ah-ha moment) send options: internet and remote port number 9. Hitting the Wake me up button, you will get a message that Magic packet sent to ip address. You need to make sure that the IP address is identical to your lan address, not modified to end in 255. It must be exact!. If this works, then give it a whirl at a location outside of your lan, your local coffee shop or wherever they have internet access and you should be able to access/wake your pc.

8.   A couple thoughts/suggestions. As you are trying to get this to work,  especially as you are doing this away from your network, you may want to setup your router to allow remote administration. To do this go to TOOLS>ADMIN, at the bottom of the page click on Enable Remote Management. Under  Remote admin port, I put a port that is not the default and something less likely to be guessed (and make sure you have a strong admin password) Under Inbound filter, allow all. To access the router remotely, open internet web page, and type http://XXX.XXX.XXX.XXX:YYYY where XXX.XXX.XXX.XXX is the IP address of your LAN (the one assigned by your ISP) and YYYY is the port you have assigned as the Remote Admin port. This will give you access to your router no matter where you are.  (you can also use your ddns address if you have with i.e  http://myaddress.dyndns.com:YYYY )

Then once you have access to your router’s admin pages, you can go to the TOOLS>SYSTEM CHECK page and verify whether or not your pc has been waken by this tool using the ping function with the internal IP address of the PC. If you don’t get a response to the ping, the pc has not been awaken. 


Having followed these steps, I finally got the pc to wake on wan and wake on lan, no matter where I am located. To be honest, this has been a hell of a project, partly because I had to do a lot of trial and error, I am not fully versed in all the details of ip/subnet logic and setup and this was the first time doing it. However, I was able to get it to work. I am not guaranteeing that if you follow these steps you will get yours to work - as well as we all know there are a large number of variables in each setup. So you may need to play around a bit with things. However I know it is possible, and hopefully this steps will make it easier to be reproducible.

Good luck to all of those who undertake this and thanks to all of those who have posted their experience as each of you have contributed to my success!


Logged

hackztor

  • Level 2 Member
  • **
  • Posts: 58
Re: Router Config for Wake on Wan -, Instructions.....
« Reply #1 on: August 08, 2009, 02:02:51 PM »

192.XXX.XXX.255 works because its a broadcast address. Dlink highly advises against using this as it could be a potential security problem. I use it myself and seem to be fine in addition its the only thing that works and i need to be able to wake my computer. Newer firmwares dont work exactly this way as 1.11 does. With newer firmware u need to change the subnet to allow u to allow a different broadcast address as by default with newer firmware, dlink disallows the 255 broadcast address. So far I have not wanted to bother doing this so I just stay on firmware 1.11. I hope someday dlink renables that broadcast address as if a user is putting the numbers into the virtual server, he or she obviously wants this.
Logged

pfountain

  • Level 1 Member
  • *
  • Posts: 4
Re: Router Config for Wake on Wan -, Instructions.....
« Reply #2 on: August 09, 2009, 08:57:21 AM »

192.XXX.XXX.255 works because its a broadcast address. Dlink highly advises against using this as it could be a potential security problem. I use it myself and seem to be fine in addition its the only thing that works and i need to be able to wake my computer. Newer firmwares dont work exactly this way as 1.11 does. With newer firmware u need to change the subnet to allow u to allow a different broadcast address as by default with newer firmware, dlink disallows the 255 broadcast address. So far I have not wanted to bother doing this so I just stay on firmware 1.11. I hope someday dlink renables that broadcast address as if a user is putting the numbers into the virtual server, he or she obviously wants this.

Thanks for the additional insights... I would agree, at least from my needs, that having a broadcast address is more important than the other changes in follow on f/w upgrades. It would be nice to have some of those features AND the broadcast capabilities. Hopefully DLink will consider this in future releases.

As for potential security problems, I was a little concerned about this. But I believe that if one follows a couple guidelines, risk can be minimized: 1. Strong and different passwords on all equipment/access accounts (routers, vpns, dns accounts, etc....) 2. with WOL/WOW using the tool I mentioned above, enable a non default port for this function - Configure the router with this port for WOL and change the port in the tool to match. These certainly will not guarantee a perfect environment, but will minimize risks.
Logged

kamelie1706

  • Level 1 Member
  • *
  • Posts: 3
Re: Router Config for Wake on Wan -, Instructions.....
« Reply #3 on: July 08, 2010, 08:33:22 PM »

Hi,

I have a router DIR-635 Firmware 2.32EA Hardware Version: B1. I believe the 2 routers are close.
I have tried the virtual server settings with broadcast adress but it did not work.
Internal LAN mac wake up is working.

Any idea how I can enable that?

Logged