D-Link Enterprise > DGS-1210-Series

DGS-1210-10 - Slow speeds from outside network


Hi all!

Thanks in advance for any advice you can provide. :)

My situation is as follows -- I have a large home server that usually sat behind an ASUS RT-AC68U gigabit router, connected via Cat6 cable. From outside my network, I can connect to an SFTP server (from across the country, Boston -> Seattle) and transfer at a pretty high speed - 64Mbit/sec (Boston is the client and receiver) on a 100Mbit connection on each side. Not bad!

Lately I ran out of ports, so I picked up a D-Link DGS-1210-10 (non-POE version, hardware revision C) for extra ports and some of the advanced features I might use.

After a day and a half of troubleshooting, when my server is plugged in behind the D-Link switch and I try the same file transfer, I can barely get beyond about 8Mbit/s. Also, the transfer speed starts VERY slowly, and eventually ramps up (more on this in a bit).

Plug the server back into the Asus router directly, and back up to 64Mbit/s O_O

I tried different cables to rule out the simple stuff. I tried different ports on the D-Link switch. I disabled all "smart" features of the switch. I set the switch port to force 1000/Full. I ensured Jumbo Frames was enabled on the switch. I updated the firmware on the switch to the latest (it came with the latest already installed, but I re-flashed anyway). I turned OFF jumbo frames everywhere and rebooted everything.

Same deal - on the Asus router connected directly to the building fiber I can get much higher transfer rate to Boston than if I go Server<->D-Link<->Asus<->Internet<->BostonClient.

Internally on my own network, if I'm connected via Wifi, I get consistent speeds whether the server is on the Asus router or behind the D-Link switch - 500Mbit/sec on Wireless AC

I ran tcpdump on the sftp server during both tests with the Boston linux client, and when plugged directly into the Asus router (no D-link switch), throughput is a solid 50-60+ Mbit/sec. Window scaling is a solid 66560 from server->client and client->server it ramps up by about 1.2MB/s until it peaks at 3.2MB just around 3s into the data transfer. It stays there the whole time. I get a consistent ~5000PPS

When the server is behind the D-Link switch, throughput from server->client, once SSH negotiation occurs, starts at about 0 and is a very fine step function every .1s or so from 100Kbit/sec until it hits ~8Mbit/sec and hangs out there for a bit. Window scaling from server->client is still good around 65k the entire time, but client->server is now a fine step function from 30KB up to 210KB, going up about 30KB/sec.

Any advice or tips are appreciated!


Any status on this?

I'd review the user manual for any speed or QoS features on the switch or anything that is controlling speed and disable it. I believe the 1210 is a smart switch so may not be fully compatible home a home class router. I believe there are some features with in the switch that can be disabled that should help make it work right.

None. I disabled every feature I could think of, tried with jumbo frames everywhere internally and without (my packet captures didn't show anything funny happening with regards to that). No packet loss, unnecessary fragmentation, duplicate packets/acks, etc.

When I use a 'dumb' switch in its place, everything is fine. The window scaling and PPS is nearly identical to just plugging directly into the router. Somehow, introducing the D-Link causes throughput loss due to what I'm assuming is the inability to scale, as that's the only indication of what could be going wrong. I couldn't find any settings that might cause that only for external connections.

For fun, I sent the pcaps to some people at work on my team and even reached out to a principle engineer to see if they wanted to take a crack at it (AWS Networking). My best assumption based on my observations is that the switch is doing something that internally is fine, but once it passes through the router (or upstream devices), something it's changing/shaping on the packet is causing havoc. While QoS isn't enabled (and it doesn't help when it is), there could still be something the switch is doing to the packets that cause upstream trouble. Or maybe it's a combination of the switch and the router (neither have traffic shaping/QoS enabled). At this point I wouldn't even rule out the router's NAT translation - haha

Oh, I also rebooted each device when I swapped network config around to ensure no arp caching/mac table was causing packets to be misrouted for any reason. Just in case.

I found the similar issue post here:

Not sure if this would be of any help.

You might phone contact D-Link support about this. They should know or have more information to help on this.

Let us know how it goes.


[0] Message Index

Go to full version