• August 11, 2020, 09:46:32 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Authentication requiered both for mjpeg.cgi and video.cgi  (Read 3283 times)

fanysoft

  • Level 1 Member
  • *
  • Posts: 3
Authentication requiered both for mjpeg.cgi and video.cgi
« on: October 26, 2016, 02:04:36 AM »

I am always getting from browser request to enter credentials when accessing cameras even I added those into URL.
What is wrong ?

http://192.168.1.108/video.cgi?user=admin&pwd=some

« Last Edit: October 26, 2016, 02:06:18 AM by fanysoft »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49052
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Authentication requiered both for mjpeg.cgi and video.cgi
« Reply #1 on: October 26, 2016, 07:07:39 AM »

Link>Welcome!

  • What Hardware version is your DCS? Look at the sticker behind or under the camera.
  • Link>What Firmware version is currently loaded? Found on the DCSs web page under status.
  • What region are you located?

Please review these to see if they will help any:
http://forums.dlink.com/index.php?topic=50328.0 and http://forums.dlink.com/index.php?topic=64975.0
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

fanysoft

  • Level 1 Member
  • *
  • Posts: 3
Re: Authentication requiered both for mjpeg.cgi and video.cgi
« Reply #2 on: October 26, 2016, 08:26:43 AM »

   
Quote
What Hardware version is your DCS? Look at the sticker behind or under the camera.
I have 2 of them :
1 is Firmware Version   1.16.04 (2016-09-09), Hardware Version   A
2 is Firmware Version   2.14.04 (2016-09-09), Hardware Version   B

   
Quote
Link>What Firmware version is currently loaded? Found on the DCSs web page under status.
see above

   
Quote
What region are you located?
Europe, Czech Rep

Quote
Please review these to see if they will help any:
http://forums.dlink.com/index.php?topic=50328.0 and http://forums.dlink.com/index.php?topic=64975.0
Still no luck, I got authentification dialog, once I add it it runs OK (and after some time I got Save as dialog to save video.cgi)

 <iframe src="http://192.168.1.108/mjpeg.cgi"
           width="460" height="345" class="smart_sizing_iframe noresize"
             frameborder="0" scrolling="no" >
           </iframe>


« Last Edit: October 26, 2016, 08:48:16 AM by fanysoft »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49052
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Authentication requiered both for mjpeg.cgi and video.cgi
« Reply #3 on: October 26, 2016, 09:06:09 AM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2186
Re: Authentication requiered both for mjpeg.cgi and video.cgi
« Reply #4 on: October 26, 2016, 10:00:50 AM »

Use IE? Save your password?
You'll still get prompted by it should be saved.
Logged

fanysoft

  • Level 1 Member
  • *
  • Posts: 3
Re: Authentication requiered both for mjpeg.cgi and video.cgi
« Reply #5 on: October 31, 2016, 09:28:35 AM »

OK, solved

Correct URL is
http://user:password@192.168.1.108/mjpeg.cgi
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49052
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Authentication requiered both for mjpeg.cgi and video.cgi
« Reply #6 on: October 31, 2016, 09:34:58 AM »

Glad you figured it out. Thanks for posting the correct info. Hope it helps future users.

Enjoy.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!