• January 17, 2021, 05:39:32 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Unable to map DNS-320L On Windows 10 64 Pro  (Read 19413 times)


  • Level 1 Member
  • *
  • Posts: 3
Unable to map DNS-320L On Windows 10 64 Pro
« on: February 08, 2019, 11:31:24 AM »

Hi everyone,

After trying tons of solutions available on the Internet, i am so desperate that I decided to create a topic.

I have purchased a D-link DNS 320l recently (its used), and after several hours of trying I cannot map the NAS as a drive.

- D-link DNS 320 l connected to Gigabyte LAN (1000) to my router TP-Link Archer C2  via UTP cable.
- PC Windows 10 64 bit, Gigabyte LAN adapter, connected to TP-link router via UTP cable.
- NAS is switched on, 1 drive is there, blue LED is on.

NAS Firmware is
Firmware Date   

Network setup:
NAS IP address: (Static, reserved IP address in router, reserved IP in Dlink NAS admin page)
PC IP address: (same as above)

The NAS (this is how I named it during the installation) is visible in My computer, but like a UPNP device, if I open it I only find 3 folders there: Music, Photo, Video. But there is no option to delete, or create any files there..
Right clicking on the icon you can see information about the NAS, so its recognized

Clicking on the NAS on the 3rd page opens up the admin console from the browser.

HDD is recognised , can be formatted with no issue from the Wizard, or from the ShareCenter setup.
on the NAS admin page/Network Share settings tab I created one share called Volume_1, All users have write and read rights, NFS host is pointing "*"

I can ping the NAS successfully with IP from CMD with no packet loss.

I tried to install the device using Share Center setup utility software, selected fix ip and set the proper settings, but at the end its not mounting up. The installation goes through successfully.

Tried several ways to map it manually from My Computer, Map network drive:
only the IP \\
Neither worked.It says Windows cannot access x...x. (address which I tried)
Diagnosing wasnt work either, there was no problem identified by Windows.
I tried to map it with and without credentials as well (NAS's credentials, local admin (myself having the Windows admin right), or creating a new user on the NAS and give rights to the user as well, no success.

If I click (in the Map Network drive tab) on Browse I only see the Network and my PC. If I click on Network nothing happens.

Tried to map it with the D-link Storage Utility software, but it gives the error Failed to Map drive (however it recognised the NAS and all settings, it was asking for credentials as well which I gave and it accepted.

What I have also tried already:
- Turn Windows feature SMB 1.0 CIFS client and server on
- ALl Windows sharing options are enbled
- in Lan Adapter properties, IP4 properties, Advanced TCP/IP settings, WINS tab the Enable NetBios over TCP/IP option is already enabled
- Tried to reboot, reinstall NAS several times

Any idea for this issue?
 :( :( :(


  • Level 1 Member
  • *
  • Posts: 3
Re: Unable to map DNS-320L On Windows 10 64 Pro
« Reply #1 on: February 08, 2019, 12:35:36 PM »

UPDATE: I used Hyper-V and created image from Windows 2016 STND , put the VM in the same subnet, and it can access the NAS easily, I could map it for the first time!

Now im pretty sure the problem is related to Windows 10 and not to NAS.
« Last Edit: February 08, 2019, 12:51:50 PM by sziba1990 »


  • Level 8 Member
  • ***
  • Posts: 1480
Re: Unable to map DNS-320L On Windows 10 64 Pro
« Reply #2 on: February 09, 2019, 03:51:36 AM »

Yes, it is a windows 10 problem because Microsoft has been playing about with the SMB protocol moving it from 1.x to 2.0 without giving backwards compatibility.  The other thing to be aware of is that the problem only applies to some versions of win 10 - they corrected it in one update but the next one removed the correction.

I haven't seen any problems using Linux or OS/2 to connect to any of my NAS boxes although some of my friends with win 10 notebooks do have problems.


  • Level 1 Member
  • *
  • Posts: 3
Re: Unable to map DNS-320L On Windows 10 64 Pro
« Reply #3 on: February 09, 2019, 03:54:45 AM »

I sorted this out yesterday.

Guys you need to do 3 things:

- Get Windows 10 1089 update (october)
- Switch on Network Sharing settings in Windows, enable options
- Turn Windows Feature SMB 1.0 On

I had 1803 windows, that was the reason Windows blocked the connection anyway.

Then I updated the windows and it was working, but funny thing today I switched on the PC and the update broke all partition tables, which I could not fix anyhow..

reinstalled win 10 x64 pro 1809 and its finally working...

It gave me a 2 days troubleshooting :D


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49459
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Unable to map DNS-320L On Windows 10 64 Pro
« Reply #4 on: February 09, 2019, 09:57:30 AM »

Additional Information:

Enjoy.  ;)
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.